Video Screencast Help

Ghost imaging modes?

Created: 22 Jun 2009 • Updated: 21 May 2010 | 9 comments
This issue has been solved. See solution.

We would like to move into using Ghost instead of Rdeploy because of the ability for file preservation but have noticed that it's slower than Rdeploy.

A little background...

We have 6.9 SP1 Build 365 obviously. We don't use PXE. We have Cisco content engines where the image is stored locally so the WinPE boot disk actually maps that location to pull the image down. We have shrunk it down so this image is a little over 2 GB.

Rdeploy takes about 8 minutes. Ghost (for the same image that we pulled) takes about 13 minutes.

Here is the command line we're using:

To pull the image:
f:\ghost\ghost32.exe -clone,mode=pdump,src=1:1,dst=f:\images\windows\BAS 5_pre.gho -sure -z9

Then to push the image to a machine:
f:\ghost\ghost32.exe -clone,mode=pload,src=f:\images\windows\BAS5_pre_te st.gho:1,dst=1:1,szeL -sure

Anyone have any suggestions? Is there a switch we're missing? Are we not choosing the correct modes?

What is the difference between pload and load?

Comments 9 CommentsJump to latest comment

Randall Newnham's picture

The issue is probably that you are using the highest level of compression. The greater the compression, the greater the time to take or deploy an image. I believe that if you tried this with an image taken with Fast compression your would see better speed.

SOLUTION
Cobra7's picture

I agree, -z9 is a bit too much, try -z2 (High compression) or -z1 (fast compression). If I remember right the amount of space you get from -z3 or higher isn't very much compared to the time it takes to backup and restore.

Randall Newnham's picture

Cobra7 is indeed correct; the amount of compression does not increase significantly beyond High (-z2) compression. If every MB is ~absolutely~ critical, then it might be justified to use -z9, but you are always trading performance for efficiency. The Fast (-z1) compression usually results in an image about 55% of the used space of the drive and is typically the most desirable, as it is faster than both no compression and High compression.

camaroguy's picture

So it now pulls the image at a very nice speed or 400 to 350 MB/min. and with the z1 or z2 switch the image is still a nice size.

But push that same image it is slow 253MB/min or slower.

Here is the comnand line we use

ghost32.exe -clone,mode=load,src=f:\images\windows\BAS5_pre_2.gho,dst=1:1 -szee -sure -auto -ntil -ntic -nousb

what is making it slow....

Randall Newnham's picture

It is possible that the drivers that WIndows PE is using for that hardware may need to be updated. Here are the most recent SATA controller drivers from Intel:

https://www-secure.symantec.com/connect/downloads/...

These are Windows Vista drivers, which is what WinPE uses in the PreOS environemnt.

What is the network card? Updating the Vista drivers for that would be a good idea, as well.

camaroguy's picture

thought of that.  Here is why I dont think that is problem because pulling the image it is fast.  Push the image it is slow.   Also push the image using rdeploy is fast.  

Randall Newnham's picture

What is the make and model of the machine? It may be a good idea to consider the drivers. The rdeploy is using different drivers, since it is running in DOS and not WinPE. It seems to me like the issue may be the storage driver. I have seen several cases where an up-to-date storage driver has resulted in a different throughput speed due to more efficient access of the disk. The link I provided above is for the drivers for Intel's ICH9 and ICH10 controllers, which are the most likely if these are new machines.

camaroguy's picture

Ok well give it a try.  It is a Dell 745.