Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ghost is in a loop

Created: 23 Jul 2014 | 18 comments

Trying to capture an image of a win7 x64 on a hp 650g1.  I have watched ghost finish and restart several times.  I took a look at the logs on the log viewer and I keep seeing the following error occuring durnig the several times ghost has restarted and during the imaging process.

 

Unhandled exception.
The file '/Altiris/NS/NS/Agent/CreateResource.aspx' does not exist.
   [System.Web.HttpException @ System.Web]
   at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
   at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)
   at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Exception logged from: 
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.NS.UI.AltirisWebApplication.Application_Error(Object sender, EventArgs e)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at System.Web.HttpApplication.RaiseOnError()
   at System.Web.HttpApplication.ApplicationStepManager.ResumeSteps(Exception error)
   at System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
   at System.Web.HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
   at System.Web.Hosting.ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

 

Need help to figure this out.

Operating Systems:

Comments 18 CommentsJump to latest comment

omishra2002's picture

It’s NS agent getting restarted or not able to report back completion status of Imaging Task ( to be reported back to Task Server). So incomplete task is hold up in queue until it is failed or timeout. As next available task from queue, imaging task is rescheduled again (and again). Ghost is getting launched through rescheduled task. This is not Ghost issue.

Could you please elaborate more on version of Altiris Deployment Solution? This issue seems to fixed by Altiris team as part of 7.5_HF2 release.

mikeb90's picture

We are using 7.5 SP1 on a Server 2008  standard R2 x64.

omishra2002's picture

Please see to recreate the WinPE environment and try again. It seems you have latest binaries released with 7.5 .SP1.

mikeb90's picture

I have recreated the WinPE enviroment.  Now I receive the message restarting DHCP client service.

mikeb90's picture

I have installed all the NIC dirvers for the HP 650 G1 and hard drive drivers for the same laptop that would be acepted.  Recreated the preboot then tried to image process again. I still get the message restarting DHCP client service.

ICHCB's picture

If you do a ipconfig /release and then an ipconfig /renew does it pull a new valid IP.   If so then can you ping the NS server?

Genneraly this restarting DHCP is a result of not having a correct driver in the PE environment for the network card.   If the driver was loaded recently to the NS then rebuilding the PE package will be needed.   I would fist confirm that the Driver truely isn't loading and then go from there to troubleshooting why it wasn't added to the PE if it was added to the Console.

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

mikeb90's picture

Yes I have the correct drivers for the NIC card imported into the Driver management Preboot.  I have also recreated the preboot environment nad made sure the bootwiz has kicked off and run on the site server.

Are there other settings I need to look at on the NS or SS to correct this issue?

mikeb90's picture

Yes I have the correct drivers for the NIC card imported into the Driver management Preboot.  I have also recreated the preboot environment nad made sure the bootwiz has kicked off and run on the site server.

Are there other settings I need to look at on the NS or SS to correct this issue?

Gavin Sanish's picture

Hi  Mike,

 

    Can you just post the extac NIC name of the computer. Becasue "Restarting DHCP client retry" is the error in the virtual partion because it dosnt load the network drivers. So we have to check for the drivers.

--

 

...

G. Gavin Sanish

T : +91 9884877206
&a
mikeb90's picture

The NIC is an Intel ethernet copnnection I217-V.

 

Here is the Device IDs

PCI\VEN_8086&DEV_153B&SUBSYS_1993103C&REV_04
PCI\VEN_8086&DEV_153B&SUBSYS_1993103C
PCI\VEN_8086&DEV_153B&CC_020000
PCI\VEN_8086&DEV_153B&CC_0200

 

if there is any other information you need please let me know.

 

Gavin Sanish's picture

Hi Mike,

 

     Try adding these drivers in the preboot and recreate and try it.

AttachmentSize
WINDOWS8-x64.zip 516.92 KB
WINDOWS8-x86.zip 372.9 KB

--

 

...

G. Gavin Sanish

T : +91 9884877206
&a
rscovel's picture

You could try testing the driver versions without rebuilding WinPE all the time following this article:

http://www.symantec.com/connect/articles/do-i-have-correct-driver-winpe 

Russ Scovel
Inside Systems Engineer

Altiris SOS – Endpoint Management and Mobility
Symantec Corporation 
www.symantec.com

Thomas Baird's picture

OK - can I distract from a focus on drivers here really quick?  If ghost is running, and you're getting an IP addy, might it be possible the drivers are just fine and we should look for something else?  Especially if an image is actually created.  IS one created, or does ghost launch and then die?  I'm guessing it's making an image.

See, if there's no network connection, it can't really get the job, right?  It should just sit there.  Ghost is in the automation environment, so that CAN run without a job, but my bet is that based on other information here, it HAS network connectivity.

 

First, can you verify if an image is ever created?

If so, then ghost is working fine and we need to find out why it's running again.  You should be able to read the log showing Ghost running, then look at what fails AFTER that.  I know there are articles on reading those logs because I wrote them.  The problem?  I've not paid any attention to them in 3 months due to... well, stuff, so I'd have to go look them up.  But if you can't find the error, I'll dig them up and help you find it.

 

Keep us posted, and if you want, ping me directly.

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

mikeb90's picture

inside this file location D:\Altiris\Altiris Agent\Package Delivery i did find find four folders that werer not the same all on the 7-23-14 each folder in the cache folder there looked to be a full image.  THe file extensions for the first one is .gho all otheres are .ghs.

image.PNG
mikeb90's picture

So I did a quick search in the drive that we have Altiris installed on for .gho.  I found that there are 4 image  of the exeact same name and size on the same day about an hour apart.  The day this happen is when ghost just kept looping and the create image job timed out. 

 

 

gho.PNG
Thomas Baird's picture

OH?  The image job timed out?  Huh.

So, first, please just forget the drivers - obviously it's working, right?  I hope we can all agree with that.

If it's "timing out" then that indicates one of 3 things:  1) the CTDataloader service is NOT reporting back to the NS the status of the task, or 2) the task is not actually completing and is waiting for something.  3) something is bouncing services on the task server.

The first of those is pretty easy to detect and fix.  Boot to automatoin, send a simple task like a run script VBS task with:

msgbox "hi"

It'll pop-up on the system in automation (do this instead of an image) and you can click OK.  After clicking OK, if it never reports back "Yup!  Done!" then you know CTDataloader is failing on the task server.  Bounce the services and/or box as a starting point.

The second option is a little trickier, but I'm sort of thinking NOT.  You would troubleshoot this by looking at the deployimage log in the x:\symantec\deployment\logs folder.  There are other logs there and if you can, get all of them after it has looped at least once.  But that log should tell you something about what is happening.  You can see the GHO file being created and ... then what?  It may SOUND tricky to read, but it's not.  Just persevere and you'll find something that might indicate an error or failure.

The third option is all that makes complete sense, but it's weird.

Generally, we see a task restart if the Object Host service on the Task Server bounces - hard.  It looses the completion status of a task, then checks back with the NS for running tasks, and launches the task again.  This doesn't happen often (especially anymore).  But, you might check the Windows Event logs on the Task Server this system is reporting to to see if there are errors about Object Host, CTDataloader, or ... something.

 

Note: Depending on what you find in this, you MAY need a remote session to troubleshoot it and may need to call it in.  Just... be careful.  As you saw early in this post, some troubleshoot the wrong thing.  I know personally the people doing backline support and they're excellent, but reaching them can be ... interesting, so hold firm if you call in and they try to do something you don't think makes any sense.  Stand your ground.  Don't just reinstall something "just to try"  That can get pretty costly in time to fix!

 

Anyway, let us know!

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

Thomas Baird's picture

Actually, I want to modify my response.

You said in the first post that you keep seeing '/Altiris/NS/NS/Agent/CreateResource.aspx' 

The response immediately after I didn't understand, but they sound like they're on track.  Huh.  What a waste, since he was on target at the very start and then we got sidetracked.

So first, if that file IS missing from the site server, there's a problem, but the task SHOULD simply fail, not restart.  Restarting happens if some services are bouncing on the site server.

 

1) Is it the SMP server or a remote site server where the images are being created?

2) look at the windows event logs for the Altiris Agent, or Object Host or CTDataloader being unexpectedly terminated and then restarted.

3) be sure the agent on this location in #1 above is fully upgraded - all agents and subagents.

4) if you have another site server, look for that file - the createresource.aspx and the directory it's in and see if there are files missing from the site server having the problem.

 

That should be a start.

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

mikeb90's picture

UPDATE:

 

We ended up rebuilding NS because of other issues with a driver that could not be fixed with installing the correct drive.  Since then we have been able to capture images of at least one of our target machines and will be working on ithers as needed.