Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ghost Write Error 19944

Created: 29 Oct 2008 • Updated: 21 May 2010 | 6 comments
This issue has been solved. See solution.

Hi guys,

 

We have recently installed GSS2.5 at my workplace and Im trying to create an image from an hp dc7800 PC. 

 

I have created a reference machine on one of the dc7800s, installed the console client and run a create image task from the console.  I also set the task to run sysprep.

 

The client PC runs sysprep fine and then reboots into WinPE-512. Ghost starts up and connects to the ghostcast session, however, it imediately disconnects and shows an error on the client along the lines of "Ghost write error, ghostcode 19944".  The client then reboots, starts the mini-setup and goes back into XP.

 

Anyone heard of this error message?  I cant get anything from google or searching these boards.  Help would be very much appreciated.

 

----------------------------------

 

c0ne

Discussion Filed Under:

Comments 6 CommentsJump to latest comment

c0ne's picture

Could really do with some help here. :smileysad:

i3igi3yrd's picture

We received a similar issue a while back when Ghosting using 8.2.

After contacting symantec, they said that it was possibly an issue with the image. This was caused because we had moved the image from one source to another (and accross the WAN).

 

Try creating a test image if possible and see if that works. If so, I'd say its time to recreate your image. 

Have you tested this task and image on another machine?

c0ne's picture

Thanks for the response I3igi3yrd, but I think you misunderstood me. 

 

Im not trying to restore an image, the taks that fails is an Image Create task.

 

 

I cant believe that I cant find any reference to these elusive "ghostcodes" anywhere on the net.  Whats the point in giving an error code if we cant find out what the code stands for.  :smileysad:

Eugene Manko's picture

This error is from multicast layer. Ghost was trying to write a packet and it has failed. Please check that your switches/routers are OK with multicast protocol especially if this error happens in the very beginning. If it happens somewhere in the middle there could be timeout and connection dropped (perhaps?) but if it happens right in the beginning more than likely it is your network setup.

Hope this helps.

SOLUTION
c0ne's picture

I've done a little more testing and have discovered that if I create a standard ghost boot disk with WinPE then I can load ghost and create/restore images using the peer-to-peer method. 

 

If I try to manually setup a ghostcast session then i get the same error as I do when running the task in from the console.

 

Eugene - I dont think the problem is with the switches (no routers inbetween server and client).  The reason being that we used to have GSS1.1 running in this environment and that was able to multicast no problem.

 

Also, I have tried setting the network options to unicast and I still get the same error.

 

ABORT: (512) Ghostcast write error, ghostcode 19944.

 

 

Any other ideas? 

c0ne's picture

Eugene - Ok, maybe I should've given you a little more credit.

 

I just spoke with the one of our other techs and discovered that we replaced one of our older switches with a new gigabit managed switch about a month ago.  Why noone bothered to mention it at the time, or any time since, seeing as I had already discussed the ghost troubles I was having with the whole team.

 

Anyway, repatched things to come from a different switch and ghostcasting works again!

 

Thanks heaps.  :smileyvery-happy: