Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Ghost32 does not work after upgrade to Windows 8

Created: 13 Feb 2013 | 7 comments

Our company has been successfully using ghost to create and restore cold images for quite some time without issue. On a recent set of computers I have just completed "upgrading" (we'll see if that's actually accurate or not) to windows 8 from windows 7. Ghost worked fine to create images of windows 7 on these computer before the upgrade. Now, after the upgrade I can not get ghost to run.

We are using Ghost 11.5 and booting from CDs with Windows PE on them. This has worked great previously, with all operating systems from Windows 3.11 up to Windows 7. Now however, when I try to run ghost32.exe it just flashes up a DOS window quickly and then it closes, returning me to the DOS prompt. The BIOS is up to date, according to Dell's website so I don't think there's a problem there.

Any ideas on what's going wrong?

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

EdT's picture

https://www-secure.symantec.com/connect/blogs/ghost-solution-suite-251-support-matrix-windows-8

That link is to the support matrix for windows 8, as Ghost has not been updated for a while and therefore does not support Win 8 innately.

However, what other checks have you carried out?  Can you see/read the local hard disk(s) from the WinPE command prompt. If not, you may be missing the necessary SATA drivers in WinPE, although if the same model of machine booted previously then it should not be an issue.

What command line is being used for Ghost ?

What happens if you remove the hard disk from the target machine?  If it still fails then that would suggest more of a hardware related area as being responsible.  Did you do any bios flashing as part of the upgrade?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Pete Gomersall's picture

Have you any 3TB USB3 removable drives attached? Ghost32\64 crashes immediately in this situation. A 2TB USB3 works fine though. Other than that Ghost32\64 works fine with W8 from a W8PE on flash drive.

MikeVanG's picture

I'm not a very experienced user of ghost, basically we've been doing the same thing with the same boot disks for years, and it was all setup by someone who has since left the company.

To answer some questions:

this is the command line

ghost32.exe /setosdrives /blind >> x:\ghost\startlog.txt
start ghost32.exe

I have not tried removing the hard drive, and I don't think the bios was upgraded as part of windows 8 upgrade. Unless the windows installer does that, I doubt it was.

I did have 3TB usb drive connected.

I have since installed GSS and created a new boot disk. With the 3TB drive attached It will boot to the "About Symantec Ghost" screen, but the keyboard and mouse (both USB) aren't recognized, so I can't continue. I'm guessing that I didn't properly add the usb drivers to the boot disk? I don't really know what I'm doing there.

I also tried using the old boot without the 3TB drive attached, and it now does the same thing as the new boot disk. Boots to the "About Symantec Ghost" screen, but I can't click the OK button to continue.

 

Pete Gomersall's picture

With 3TB removable Ghost will in my own experience crash immediately after it attempts to enumerate the drives. Try with a smalled drive attached. You shouldn't need any extra USB drivers - these should be standard in PE. Are you using W8 version of PE? I would suggest downloading this if you are not using it already.

MikeVanG's picture

I'm using whatever version of PE that Ghost uses when it creates a boot disk, I think it's Vista. I'll try to find Win8 PE and see if that does anything.

MikeVanG's picture

FYI, I just tried this again, with the original ghostboot disk from years ago, with the 3TB drive not connected, and it worked fine this time. Mouse and keyboard responded normally. Nothing has changed on my end so I'm not sure why it would work now, unless it was user error before (not ruling that out.)

 

Then I tried again with the 3TB drive connected and it's back to the original behavior, where the "About Ghost" screen flashes up briefly then disappears, only now the mouse is responding. So it's definitely the 3TB drive that's causing it. I will try again with some of the smaller drives we have.

Starting to get this figured out. Thanks.

 

Edit: seems to be working just fine with the 2TB external drive. Thanks everyone.

pkaurav's picture

Hi,

Is your machine UEFI enabled? Can you share output of msinfo32.exe and model of 3TB disk?