Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ghost32.exe compatible with 3TB drives or not?

Created: 10 Jul 2012 | 9 comments

Hi,

I searched the Symantec forum and couldn't find a final answer for this question.

When using a 3TB external drive, ghost32 starts and closes immediately. No error logged into GHOSTERR.TXT. I'm using a standard WinPE-2 Ghost Boot CD with no special drivers added. The external drive is connected to the PC via a USB2 port.

Since I have two Seagate GoFlex Desk (2TB with USB2 and 3TB with USB3) and both GoFlex drives are interchangeable with the USB interfaces, I tried the following:

2TB with USB2 via USB2 port = no problem

2TB with USB3 via USB2 port = no problem

3TB with USB2 via USB2 port = ghost32 starts and closes immediately

3TB with USB3 via USB2 port = ghost32 starts and closes immediately

So, ghost32 seems to have a compatibilty issue with 3TB drives.

Or, what should I do to make it work?

Comments 9 CommentsJump to latest comment

EdT's picture

What actual version of Ghost are you using?  How is the 3Tb external hard disk partitioned?  You cannot have a single 3Tb partition unless you choose to use a GUID partition table.  I am not sure if WinPE-2 supports GUID partition tables, but for sure WinPE-3 does, as it's based on Windows 7 kernel which has no issues with 3Tb drives with a GPT.

You could try partitioning your 3Tb drive to 2Tb and 1Tb and see if this makes a difference.

When it comes to USB-3, you may need to add drivers to WinPE-2 for both the USB-3 chipset on the motherboard and also any drivers required by the USB-3 drive itself.  I have found this necessary with WinPE-2 as it does not have native USB-3 chipset support and the USB-3 drive I was using also came with drivers for different operating systems which I needed to load in WinPE-2 to get the full performance.

If you want to roll your own WinPE-3.1 boot environment, see this article:

https://www-secure.symantec.com/connect/articles/adventures-winpe-31?om_ext_cid=biz_con_cmgr_cp_20120221_pm

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

myriaxis's picture

I'm using ghost32.exe 11.5.1.2266.

The GoFlex USB interface is seperate from the drive. So I can mix and match the drives (2TB or 3TB) with any USB interface (USB-2 or USB-3). Even though I have an external USB-3 interface, my PC only has USB-2 ports. My understanding is that an external USB-3 interface plugged in a USB-2 port should operate like a USB-2 interface.

I tried different combination of partitionning. At first, I used a full 3TB and of course it didn't work. I also used one 2TB partion leaving the rest unallocated and it didn't work. I tried 2TB with 1TB partions and it didn't work. Now I have 2x 1.5TB partitions and it still doesn't work.

I'll try the WinPE-3.1 boot environment and see if it makes a difference.

Thanks for the tip. I'll post the result in a few days.

EdT's picture

I suspect your 3Tb drive, which is not mounting in any partition format you have tried on a USB-2 port, may require a device driver to be added to WinPE.

I have a 1Tb pocket hard disk that is USB-2 but still needs a device driver under Windows XP to access the full capacity, so this is by no means a unique requirement.

Try plugging your drive into an XP system and see if it mounts OK on that - it will soon tell you whether a driver is required.  This is likely to be a quicker check than building WinPE 3.1, which may also require a driver added if your USB device needs one.

Some large USB drives come with a manufacturer partition that emulates a CDROM drive which then provides the source for drivers and will autorun on a normal windows PC. If you have some driver files that came on the USB hard disk (I hope you backed up any content on the drive before reformatting it !!) then you can load them dynamically at the WinPE command prompt from a USB stick (for example).

Just type DRVLOAD <path to drive INF file> and the driver SYS and CAT files associated with the INF file will be loaded by WinPE and the command prompt will then tell you whether the driver loaded successfully. As long as the driver is the correct one for your USB device then you should be able to access it after the driver has been loaded.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

myriaxis's picture

Hello EdT,

I tried my drives with a USB-2 interface on a XP MCE SP3 machine via USB-2 port.

2TB drive with 2TB partition is mounted OK on XP. I see a 2TB partition.

3TB drive with 2x 1.5TB partitions is mounted OK on XP. I see 2x 1.5TB partitions. No driver asked. However, it might have downloaded drivers automatically from Windows Update. How can I tell?

Just to be sure, I tried again my drives with a USB-2 interface with GSS Boot Disk.

2TB drive with 2TB partition = ghost32 starts normally.

3TB drive with 2x 1.5TB partitions = ghost32 starts and closes immediately.

What's next? WinPE-3.1?

EdT's picture

That would be my suggestion. From what I recall of past postings by Nigel Bree, one of the Ghost developers, they did validate Ghost against some early "advanced format" drives and with GUID partition tables, so I don't believe the issue is with Ghost itself.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Pete Gomersall's picture

All,

I submitted a post to this forum just after 3TB drives became available about this exact problem.

The issue still occurs on W7 and W8 based versions of PE for both x86 and x64. Gost32\64 crashes.

This occurs on all (WD) 3TB drives we have (we do not have other brands to test with). It seems unrelated to PE or USB 3 as we have other USB 3 drives working fine over both USB2 and 3 ports. Updating the drives firmware has no effect. Ghost still crashes when it tries to enumerate the disks. The number and size of partitions is irrelevant.

Pete Gomersall

myriaxis's picture

Well, as Pete confirmed, WinPE-3.1 doesn't fix it.

I got a bit further by getting a Ghosterr.txt indicating a 36000 error.

I used EdT procedure to create a WinPE-3.1 x86 boot disk.

I tried to create a WinPE-3.1 x64 boot disk, but failed to create a bootable ISO. I modified EdT script to replace x86 by ia64, but the last two commands need a bit more work. If you have them handy, it would be appreciated.

Here is the ghosterr.txt file generated during my test if it may be of some help.

Thanks for your time on this issue.

AttachmentSize
ghosterr.txt 8.23 KB
EdT's picture

You don't need a 64 bit version of WinPE to image any drive, as the normal situation is that you are booted into WinPE and the target drive is nothing more than a collection of sectors that need to be recorded. 

At this point it may be worth opening a call with Symantec. There are some engineers in Pune who have produced various patches to Ghost in the past, and maybe this is something they can help with.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

myriaxis's picture

Unfortunately, I don't have a business support account with Symantec. I can't create a technical support case.

I guess I'll have to wait for an eventual new version of Ghost.

Thanks for all your help!