Video Screencast Help

Ghost32.exe under WinPE x86 - problem - unable to detect hard drive

Created: 28 Jan 2014 | 3 comments

I read posts that stated that there is no need for Ghost64 when using WinPE.  However, I am encountering a problem.  x86 WinPE is unable to recognize the hard rive.  x64 WinPE is able to recognize the hard drive.  It is a Dell R7610 model.  This model driver for the storage controller only contain a 64 bit.

WinPE x86 - Unable to recognize hard drive - can use Ghost32, but can't detect hard drive
WinPE x64 - Able to recognize hard drive - cannot use Ghost32, but can detect hard drive

Is Ghost64 the solution?  Any other solutions?

Thanks!

Operating Systems:

Comments 3 CommentsJump to latest comment

EdT's picture

If Dell only provide a 64 bit driver for this model, it is always worth checking what hard drive chipset is being used in case the chipset vendor has alternative drivers you can try.

However, if WinPE x64 works with the driver and can detect the hard drive - have you checked whether the Ghost32 client will actually run under Ghost64 or does it refuse?  You should be able to use Ghost64 though - have you tried this yet?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

EdT's picture

You haven't mentioned what version of Ghost you are using, but I would assume it's 11.5.1.2266 and you are working with the WinPE version that comes with it. If this is correct, perhaps you should consider using a later version of WinPE as described here: 

https://www-secure.symantec.com/connect/articles/c...

This should enable you to use Win 7 drivers instead of Vista drivers, just in case you can get Win 7 32 bit drivers for your machine.

If I recall correctly, the Ghost64.exe program is intended for hot imaging of running 64 bit operating systems and was not intended as a 64 bit version of Ghost32.exe.  However, have you checked the Ghosterr.log file? There may be another reason for the freeze.  Nevertheless, I still recommend checking the chipset and looking for drivers on the vendor site.  Finally, bear in mind that you must use drivers appropriate to the version of WinPE you are using, regardless of the version of Windows you are trying to image.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.