Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Ghost64.exe Question 1873 Deploying MBR/BIOS Images In GPT/UEFI Mode

Created: 05 Feb 2013 | 6 comments

Hi All,

I have a question regarding UEFI deployment of Images that have been captured in MBR/BIOS mode.

 

In a nutshell:

I am creating a WinPE V4.0 image that will be deploying both Win7/Win8 Ghost and Wim images. There is a large catalogue of Win7 images that were captured in Legacy BIOS mode. Is it possible to deply these images in UEFI Mode AUTOMATICALLY?

I know the images can be deployed if the user answers 'NO' to question 1873 (convert to GPT Yes/No). However I would like no user interaction. When the -sure switch is used it defaults to 'YES' and attempts to convert the image (error 36000 appears).

Is it possible to force select MBR/BIOS deployment or 'NO' to Question 1873? I really dont fancy converting hundreds of images! Unfortunately booting in Legacy BIOS mode is not an option.

 

Thanks in advance for any help.

Comments 6 CommentsJump to latest comment

MWiegold's picture

Sorry, I should have mentioned the client will be set back to Legacy mode after imaging using WMI.

EdT's picture

Ghost does not support UEFI bioses.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MWiegold's picture

Thanks for the response, however Ghost deploys the image fine even if it is not supported. The only problem is the question that appears, I need a way of supressing it with a 'NO' response instead of the default 'YES'. Is this possible?

I am also confused by question 1873 (convert to GPT/UEFI Yes/No) - Why would it ask if its not supported? If it didnt ask the question and deployed the image in the same way it was captured all of this would be fine.

I am using ghost64.exe V12.0.0.4112 if this information helps in any way.

(EdT - Im sure you are correct in what you say, just trying to work out my options :) )

EdT's picture

I think this is a question that only one of the original Ghost developers could answer (eg Nigel Bree). It is perfectly possible that Nigel included some code in readiness for coming functionality and you have someone triggered it by using Ghost64.  The question itself does not actually make sense to me as GPT is a formatting scheme for hard disks whereas UEFI is the extended firmware interface which is a bios function. I am not sure how these two are linked as you can have GPT drives without a UEFI bios as far as I am aware.

One other thing that puzzles me is the version of Ghost you are using, as the latest release in Ghost Solution Suite is 11.5.1.2266.  Are you using a file that comes with any recent version of Deployment Solution?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MWiegold's picture

You are correct - GPT and UEFI are completely separate, but for some reason they are clubbed together in the question. Anyway, It seems like this is a dead end for now, maybe future versions will support UEFI fully.

As for my version, it was not part of any suite. The file was provided directly to me for testing from Symantec resllers.

Thanks for your help.

EdT's picture

You may want to go back to your reseller and check on where this version of Ghost came from - they may be able to advise you further.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.