Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ghosting Win7 64bit client on 2008r2 HyperV host - Unattended.xml error

Created: 31 Oct 2013 • Updated: 08 Nov 2013 | 4 comments
This issue has been solved. See solution.

Ghost version is 11.5.1.2266.

I'm trying to Ghost a freshly installed Windows 7 SP1 64 Bit client that is running on a Win 2008 R2 Hyper-V host.   I installed the Ghost client through the Remote Client Install.   I made the necessary changes to allow the C$ share to be written to by the client install process.   Firewall is disabled.  Client reports successful install.

I'm using the WinPE pre-OS option.   When I attempt to image the Windows 7 machine, the task starts and I see the notification on the client machine that a task is in process.   The client machine never reboots and fails on the "To Virtual Partition" step.   With the error of: "Failed to update unattended.xml file".

I've tried deleting the INCOMING\WinPE folder.  I've tried using WinPE-512.  Same result.

I browsed the forum and read that error is typically related to the NIC or Disk Controller driver.   Since the client is running on a hyper-V host, the NIC driver on the Win7 client is reported as "Microsoft Virtual Machine Bus Network Adapter #2".   I'm not sure which driver I would need.

As a test, I tried using the PCDOS option and the client does reboot, but does not find a network driver, which is expected.

Any help is greatly appreciated!

~Rob.

 

 

 

 

Comments 4 CommentsJump to latest comment

EdT's picture

In my experience, imaging virtual machines over the network can be nigh on impossible unless the virtual drivers are available as separate downloads which then allow you to add them to WinPE.

It is also possible that WinPE V3 or later already has support for this virtual driver, but it is lacking in WinPE V2 (as used in Ghost), due to its age.

When working with VMWare virtual machines, I have had the most success using an ISO image of a WinPE boot system mounted as a virtual boot CD.  You may need to use WinPE V3 and create your own Ghost version using this release, so look for articles by Terry Bu who has documented how to get Ghost working with WinPE V3 and what limitations exist. This one in particular should help:

https://www-secure.symantec.com/connect/articles/creating-and-using-winpe31-image-gss-251

 

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Terry BU's picture

Thanks again EdT!

https://www-secure.symantec.com/connect/articles/creating-and-using-winpe31-image-gss-251

https://www-secure.symantec.com/connect/articles/faking-drivers-gss-251-winpe-31

 

those 2 articles i wrote follow one another.  The 2nd one is about getting nonvista drivers to not complain in the console using the PE you made in the first article

RobDSage's picture

I found a solution to this issue.   Within Windows Server 2008r2 HyperV Manager there is an option to use legacy network drivers instead of the synthetic virtual network driver.   When adding the legacy driver to each virtual machine, it emulates an Intel 21140 NIC which is supported in the WinPE2 that comes with GSS 2.5.1.

Here's additional info from Microsoft:

http://technet.microsoft.com/en-us/library/cc770380.aspx

After making this change, I am able to create images and tasks for virtual machines running in a Windows 2008r2 HyperV Role environment.

I'm sure the advice provided by Terry BU and EdT is also a solution if you need to use the native synthetic network drivers.

~Rob.

 

 

 

SOLUTION
Terry BU's picture

Glad to hear you solved it, and that the legacy option is working for you!

Also, the solution that EdT and I were talking about seems to be overkill for your situation!