Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

global mutex timeout and other issues

Created: 25 Jan 2013 • Updated: 04 Feb 2013 | 4 comments
This issue has been solved. See solution.

our notification server is dead.  I'm getting a lot of global mutex timeouts and any attempt to run a repair install failes with the error:

Configuration Task Configuring services... Failed:  Method not found: 'Void.Altiris.Common.Collections.Generic.EventList'1..ctor(System.Collections.Generic.IEnumerable'1..ctor

 

I'd paste the whole error but the copy paste function from the altiris log viewer never works.

 

Anyone seen anything like this?

I've already tried to create separate application pools and aexconfig /configureall. 

 

Comments 4 CommentsJump to latest comment

mclemson's picture

Did you try to perform an upgrade or install a new product?  It sounds like you've tried to install something recently.  Can you help us with what led up to this?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

chessdotcom's picture

we haven't tried an upgrade since October.  The system just became slow.  Some functions like security settings did not work.  It gave the reconfigure aexconfig /svid warning page.  I tried to do a repair. 

mclemson's picture

Did you or someone change the application identity password?  Did the application identity account become disabled or locked out in Active Directory?  If so, check:
http://www.symantec.com/docs/HOWTO10009

Launch SIM and run a repair of the Symantec Management Platform and solutions.  Does it succeed?  Does the console load?  Are the Altiris-related services started and in a Running state?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

chessdotcom's picture

no, nothing was changed.  In fact, I tried the repair and it failed configuring services.  So, I suspected app identity.  I ran the aexconfig /svcid command.  We still had problems.

I also noticed in sql logs app identy trouble with iis app pool identities so I switched all to network service.  That didn't fix it either. 

I then ran an upgrade to mp1.  Sql server cpu spiked then and we were getting i/o erros in sql logs.

At that point I decided to just rebuild.  We've wasted too much time. 

After uninstalling, I noticed a lot of space was still used in IIS.  Logging was turned on and we had 80 gigs of log files.  I don't know if that was the problem, but I know it isn't good.  I've cleared the logs, turned them off, and reinstalled smp.  That is my fix at this point. 

SOLUTION