Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Grayed out "Include Private Key(s)"

Created: 11 Jul 2011 | 5 comments

Hi Everyone,

I currently have PGP desktop 10.1.1 installed on one computer where I work. The computer is running on Windows XP. I have set up my private and public key set, and now wish to export those onto a server we're running, that way we don't have to redistribute our private key to clients. However, when I try and export the keys, the option to include private keys is grayed out. I am also the administrator of this machine. I've scoured for the answer for this, but haven't found a thing. Could anyone please point me in the right direction?

Thank you.

Comments 5 CommentsJump to latest comment

Suhaib's picture

I have set up my private and public key set, and now wish to export those onto a server we're running, that way we don't have to redistribute our private key to clients.

You might find the section titled Protecting Your Keys, page 81 of User Guide, useful.

 

However, when I try and export the keys, the option to include private keys is grayed out

If you open PGP Desktop, click on the PGP Keys Control box and then click My Private Keys is the key you want to export listed on the right?

AssuredControl's picture

The private key is in the My Private Keys.  When I try to export it the include private key(s) box is greyed out.  

I believe this will be a permissions problem on a PGP config file.  I am an administrator on my machine so I should have permission but the ownership may be with an earlier user account.  A misguided helpdesk guy decided he would try to fix an outlook problem by creating a new user and moving stuff across to the new account so file ownership/permissions may not be right.

Tom Mc's picture

If this is in a PGP Universal Server managed setting, the option of including the private key in key export may have been disabled for local machine installations.  You work setting might also be using a key mode where the private key is not on the local machine.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

AssuredControl's picture

I am pretty sure I am not using Universal.  Their is no indication that I am working for a remote keyserver.  

The other interesting thing is that despite the "cache for current session" being set I never have to authenticate to enable encryption or decryption.

I think I will have to uninstall and try again.

Tom Mc's picture

The option to include the private key in the export will be grayed out if you are exporting a key for which you do not have the private key.  Make sure you really have the private key by exporting from My Private Keys instead of All Keys.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &