Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

GRT-Restore of single mails in Exchange 2010 fails

Created: 24 Sep 2012 • Updated: 25 Sep 2012 | 4 comments
Caroline Kiel's picture
This issue has been solved. See solution.

Hi,

I'm at a customer site right now and we have the problem, that we can backup an Exchange-DB (2010, DAG with CAS Array) pretty well and fast, but cannot do any restores of single mails.

The error message is "Invalid Physical Volume Library Media Identifier"

I'm pretty sure to have followed all available tech notes and KB articles.

Here are the facts about the environment:
- Yes, BE is patched...
- Backup is done to classic B2D
- The account used for the backup restore is Domain Admin and has Organization Admin permissions in Exchange
- The account used for the backup restore has a mailbox (visible) and we can logon to that mailbox via OWA (we also sent some mails from there)
- All machines are within a single domain
- The BESA has all permissions on the BE Server
- The same for the account for the backup
- "Normal" file restores are not a problem
- SGMON shows "could not resolve the news-ndmp or the ndmp service error code 10109 using port 10000"
- SGMON shows "beconvertservernameplus returned error 87"
- The BE server has a teamed NIC (HP)

Hope, I didn't forget anything.

Anyone any idea?

All the best from Germany,
Oliver

Comments 4 CommentsJump to latest comment

Elias AbuGhazaleh's picture

Oliver,

Is Port 10000 available?  It sounds like you may be getting an "access denied".  Check this tech note:

http://www.symantec.com/business/support/index?page=content&id=TECH139630

Hope that helps.

Elias

Caroline Kiel's picture

Elias,
Thanks for your quick response. I'll doublecheck that tomorrow morning (GMT +2) and update the thread.
One more thing: in SGMON is seems, as if the connect from the BE-Server to itself has a problem. But there TCP10000 is bound to beremote.exe and listening. The next line in SGMON then shows that the IP is pointing to the local machine, so the connect is done to the local loop address and that seems to work.
I'll doubleckeck TCP10000 on the five Exchange boxes. (2x CAS/HT and 3x DB)

Oliver

If this post is the answer to your question, please mark it as a solution.

If you can dream it, you can do it. (Walt Disney)

JTOL's picture

Hi Oliver,

Is there more than one IP configured for Exchange servers? If so, test adding correct IP to BE Server's host file.

I've seen this kind of behavior when there was multiple IPs, but that was on Exchange 2007 cluster.

Caroline Kiel's picture

Hi,
After doing about sixtyfive billion tests today, I've setup a VM with BE2012 in it and tried the restore from there. Everything worked like a charm...
So the customer decided to destroy the old server and install the OS from scratch.
Sorry, we'll not find out, what the problem really was.
Nevertheless, thanks to you guys for your assistance and let me know, if I can help you with some other case, somewhen.

All the best and hope to see you in Vegas,
Oliver

If this post is the answer to your question, please mark it as a solution.

If you can dream it, you can do it. (Walt Disney)

SOLUTION