Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

GSS 2.5 DOS: ghconfig -noide in config task

Created: 03 Jul 2013 | 3 comments

Probably a really  tricky problem, not sure if anybody has encountered this before, but let's try

In GSS 2.5, when restoring an image from a server using the ghost console, the configuration task  (hostname, ip, domain ...) seems to use a program in the Ghost Partition (DOS) on the client called ghconfig.exe, which is run after ghost.exe has finished writing the image to disk.

Now, I have a lab with about 70 machines where ghost.exe hangs on startup with a grey screen when I try to create or restore an image. Seems to be a problem with some devices on the mainboard and/or a buggy bios. Playing with the few available bios-settings gained nothing, but then I found out that using

  ghost.exe -noide

solves the problem.

Creating an image works.

I was happy, but too early ...

When restoring an image, ghost.exe also works perfectly but afterwards, ghconfig.exe is run for configuration. I also put the configuration in a separate task, but this does not chance anything.
Of course, ghconfig.exe also hangs, probably for the same reasons as ghost.exe.
I found out that ghconfig.exe also understands the (undocumented) switch -noide, and

  ghconfig -noide ...

from the command line works as it should.

Now, my big question is, how, if possible at all, can I tell the ghost console to use ghconfig -noide in a configuration task?

I will not configure 70 clients manually

In the ghost console on the server the clone-tab in task-properties has an advanced settings option, where i can specify command line switches for ghost.exe, but in the configuration-tab there is no such thing for ghconfig - understandably, ghconfig has no documented useful optional switches...

I am starting to think about somehow hacking the Dos-Partition, putting a .bat between ghconfig and its caller, probably ngctdos.exe but the content of  ngctdos.exe is scrambled,  with a small code segment in front to unpack/decrypt it at runtime and this is going a bit far now ...

Just in case: why don't I use WinPE?
I tried, but in my case, this also does not seem to work out of the box. WinPE boots to a desktop-background with a cmd-window with a blinking command prompt and no ghost processes running. ngctw32.exe seems to have an unhealthy tendency to crash with the well-known C000005-Error.. Which means, I will probably have to (and I will do this) talk to tech support to get the latest build.

   Dietmar

 

Comments 3 CommentsJump to latest comment

EdT's picture

Might help to know what hardware you are working with. This article documents Ghost switches:

http://www.symantec.com/business/support/index?page=content&id=TECH130961&locale=en_US

Yes, for the 2269 patch, you need to speak with tech. There is a link at the top of this forum about how to get the patches.

These two articles may help with the creation of a WinPE boot environment:

http://www.symantec.com/business/support/index?page=content&id=TECH110134

https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

 

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

DietmarP's picture

Thanks for your comment, EdT

the hardware is nothing special, rather old AMD AM2-Systems. mid/end of 2014 we will replace them, but before that (of course SOON) I have to install Win7 on them.

- Mainboard MSI K9N Neo V2, AMD A2X2 5200, nForce 520-Chipset,  Realtek RTL 8111 GB NIC
- Sata HD, Sata DVD-Rom, internal USB-Cardreader

nothing else.

I already tried unplugging the cardreader, disabling IDE/USB in the Bios ... doesn't help

Simple Test:
- boot the ghostboot-partition
- press CTRL-X for a command prompt
- 'ghconfig windows'
  hangs for some minutes, then tells me 'no Windows installations found'
- 'ghconfig -noide windows'
   instantly finds windows on partition 2

Looks like ghconfig has problems finding the disk No idea, what ghost / ghconfig do not like on this system.

But it looks like the -noide switch is there for a reason smiley

The ghost.exe cmd-line switches are also covered in the docs, thats how I found -noide, but I think that ghost.exe has nothing to do with configuration.

I had to update the NIC-drivers in the WinPE-Image, but network is up and running when I boot into PE

  Dietmar

EdT's picture

DOS has no ability to see SATA devices unless the bios is set to compatibility mode at which point the hard disk looks like an IDE device.  I'm guessing that the -noide switch in your environment is forcing DOS to stop looking for a hard disk on the base IDE port and thus look further for whatever I/O port the SATA is appearing on.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.