Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

GSS 2.5 multicasting stops after a few minutes

Created: 12 Nov 2012 • Updated: 12 Nov 2012 | 7 comments

Hi

We have a set of new Windows 7 laptops that will be stored in two mobile carts that have wired ethernet connections and a switch within. I use (or planned to use) GSS wake-on-lan to boot the laptops and commence an image cast operation. The problem is that the pushing stops after a few minutes. Restarting the switch in the cart resumes the data transfer but it stops again after a few minutes. After a dozen or so restarts (of the switch) the image cast was finally successful. The switch is a D-LINK DGS-1100-16 (a model I have not used before) that supports IGMP snooping and it is enabled. Our older computers have worked fine with GSS multicasting.

Things tried so far:

  • A different switch of the same model
  • A different ethernet wall socket and a different ethernet cable
  • Rebooting all switches in the subnet
  • Verifying igmp settings on other switches. Igmp snooping was enabled on all switches but there was no igmp querier, I enabled that feature on one switch but it made no difference
  • The switch does not appear to crash, at least the management interface works even after the multicasting has stopped.

Any ideas? I will try cloning the same group of laptops using one of our older switches tomorrow, but even if it works it does not solve the problem with the carts as our old switches are too big.

Comments 7 CommentsJump to latest comment

user61235's picture

Thanks for the link. I actually did look for a new firmware from d-links website for my country, but this is not the first time that international companies don't bother to update their localized websites.

With the newest firmware a multicast using two laptops went without problems and fast. When multicasting to five computers, performance was much lower but seemed be working otherwise fine until somewhere around 50% the transfer finally stopped. I had to reboot the switch 2-3 times to complete the operation. Yesterday I had to reboot a dozen or so times, so it worked better than before (with two samples, statistically speaking this isn't a reliable conclusion).

I have not yet had the time to test the computers with a different switch, I'll try to find the time tomorrow.

EdT's picture

Multicasting which stops after a few minutes is normally caused by IGMP snooping not being enabled in your switches. Search this forum on "IGMP" and have a look at any past postings by Nigel Bree, former Ghost developer, on this subject.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

user61235's picture

As I said in my initial posting, I verified that all switches along the route from the gss console to the laptops have IGMP snooping enabled (there are a few branch switches that don't support snooping, but they are not involved in this operation). There was no IGMP querier but I enabled that on one switch as well. Multicasting has worked fine on this network, the only new variables are these laptops and the D-Link switches in the carts (snooping is enabled on them too, but if it doesn't work properly then that could be D-Link's fault. Updating the cart switches firmware greatly increased the time interval between halts, but didn't eliminate them.

EdT's picture

Are you saying that you had different switches before the DLinks were installed?  If so, can you revert to one of the known good switches and see if it works as before?

The observation that updating the cart switches' firmware has improved things considerably does, in my mind, point the finger at the DLinks, so it may be worth looking through any support forums they may have, or raising a call with them to have this checked out further.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

user61235's picture

These new D-Links were installed into the new laptop carts, they did not replace anything.

I now performed a test, again with 5 laptops but this time connected to one of our older and heavier duty switches. Multicasting completed in one go and performance was normal.

Next thing I tried was multicasting with the troublesome D-Link but with IGMP snooping disabled. My understanding was that if a multicast reaches a switch that does not support it then the stream is broadcast out of all ports. That is how it had behaved in the past, I was expecting a lower datarate then with multicasting but better then nothing and without the halts. Transmit rate was about 25% of normal multicast rate, that was surprisingly bad. It made no difference if all ports on the d-link were in gigabit mode or if some were in lower speed modes (10 mpbs is typical with powered off computers). In the past it made a big difference.

I will try contacting D-Link next.

EdT's picture

I had always thought that DLink targetted the home and small office markets, but their equipment was not really industrial grade. It may well be the case that they have not had any specific requirements nor tested the multicast performance with IGMP snooping enabled and disabled, but clearly your testing with the older switch shows that the problem lies in the DLink device.  If you get a satisfactory outcome, please detail the model of DLink switch that you used, and what was done to get it working properly, so that other users may be aware.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.