Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Hello,I would like to add

Created: 11 Sep 2012 | 9 comments

Hello,

I would like to add that we're experiencing the same problem with the HP 8570 and 8470 series laptops as well.  What's strange is the network adapter hardware is identical to that found in the 8560/8460 and even the 8540 series and those work flawlessly.

Our ghost boot usb drive was created using the Ghost Solution Suite (v 2.5 aka 11.5.1) Boot Wizard and selecting:

PC-DOS, Network Boot Package, Universal Packet Driver v2.0, and adding -NOIDE -NOUSB to the parameters.  Has worked like a charm on all model hardware before the 8570.

Already tried searching for 19913 and tried many of the solutions listed, but they didn't work (some articles were also very old so I was having much hope in them anyway).

Any help would be very much appreciated.  Thanks!

Discussion Filed Under:

Comments 9 CommentsJump to latest comment

EdT's picture

I have moved your posting into a separate thread to avoid confusion.

Although the network adapter hardware (and by this I assume you mean the chipset used) may be the same, have you physically checked that the chipset fab releases are identical? Have you checked whether the bios releases are identical?  Unfortunately, I can recall back in the NT4 days, similar issues with Compaq desktops and their network adapters - no apparent change apart from the chip fab, but nevertheless needed different drivers.

With a PCDOS boot, you are also dealing with a very old operating system that does not understand modern hardware and is also very limited in the way it addresses memory. If your new laptops are providing on chip video support, there is often a block of memory allocated to data transfer in the 640K area of lower memory where the network drivers get loaded, and you can end up with insufficient base memory to be able to load all the TCP/IP components and NIC drivers.  Depending on your familiarity with DOS and memory management, you could try techniques such as loading high with HIMEM and also using EMM386.EXE but if these utilities mean nothing to you, then move straight to WinPE.

Frankly, WinPE is now the most reliable platform for booting modern hardware as it can handle the different drivers required for SATA hard disks and optical devices, it can handle USB devices and it can handle large hard disks and UEFI bioses. Many vendors are also not providing DOS support any more.

So my advice would be to put together a WinPE boot environment using Ghost Boot Wizard, add the Vista 32 bit drivers for the hardware you need to support (as WinPE in Ghost is based on the Vista kernel) via the Boot Wizard, and then make sure the added drivers are selected before rebuilding the WinPE boot image.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

rreinstein's picture

Greetings.

I'm having the same problem with the 8470p 8570p too. No problem with PE but it is way too slow compared to our DOS imaging. Up to 3 hours for what usually takes 15 minutes in DOS. Tried many different e1000 drivers with no luck.

What is it about these HP laptops that makes them different than earlier 82579LM imlementations?

Urgently need to boot DOS on these!

Thanks,

Robert

EdT's picture

PE should not be hugely slower than DOS. Have you checked that the drivers are connecting at the maximum speed your NIC is capable of?  Some INF files set a default speed that could be 10Mbps so it is always worth checking what speed your NIC connects at (colour of connect light on switch?), and if it is slow, check the INF file to see whether there is a default that can be changed.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

rreinstein's picture

Thank you Ed. When I get back to work I will verify. It is an all Gigabit network. 

rreinstein's picture

i set up a totally segregated network and did more testing. The WinPE now images in 15 minutes - same as the DOS. We are addressing the network issues.

Thanks for your help!

EdT's picture

Let us know what you find, as this sort of feedback is helpful to other users.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

rreinstein's picture

I still have not found the source of the problem, but I will guess that the WinPE drivers are not as forgiving as the DOS drivers. Our imaging network has worked flawlessly when using the DOS boot disk, but WinPE took a long time. On the new network I created, WinPE worked even faster than the DOS version, so I will be looking into testing and/or replacing our switches. I have already replaced/repaired some of the Ethernet runs which tested below par.

ClementL's picture

Hi,

I have the same problem with 8470P.when we try to boot into DOS Managed.

I would like to test with WinPE but in HP the drivers available are only for Windows 7 !! Could you please provide me a link to download these drivers for Windows Vista ?

Thanks.

rreinstein's picture

go to the Intel website and download the Vista 32-bit drivers for the 82579LM chip.

Network Adapter Driver for Windows Vista*