Video Screencast Help

Help with 5220 configuration with SAN transport for VMware

Created: 18 Apr 2013 • Updated: 18 Apr 2013 | 3 comments
KeirL's picture
This issue has been solved. See solution.

Hi

I'm in the process of configuring a 5220 Appliance (2.5.2)  for VMware backups using SAN transport. I think I'm most of the way there in that I can successfully backup using NDB so all my credentials are good and vCentre is correctly creating and removing snapshots.

I now need to get it to work over the SAN.

I have zoned the datasotes to the vmware ports on the Appliance. I have not used the ports that would normally be used for FT connectivity nor the one for tape.... I have used the remaining two ports. I understand that multipathing is not supported and so have zoned half the datastores to one port and the other half to the other port.

If I log into the appliance and run >MANAGE >STORAGE >SCAN  - this completes ok

If I log into >STORAGE I see lots of new sd(x) entries, a size (2TB) but they all have a status of 'n/a'   Is this correct?

If I go to Maintenance and run DF -H I do not see any of these disks mounted - Should they be mounted or not?

Do I need to do anything on the appliance to configures these luns or should the appliance 'know' what to do with them automatically?

 

Essentially  - I'm after an idea of what I should see to ensure that the vmware LUNS are properly presented and perhaps a command I should run to prove this?  I suspect the SAN transport mode is not being used as the Appliance doesn't have correct visibility of the datastore LUNS ove the SAN.

 

many thanks in advance

KL

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

KeirL's picture

Hi

I've sorted this out - the issue was me being a plank.......

.....I've multiple appliances and basically was running the device scans on the wrong one.........

Thanks

SOLUTION
Rami Nasser's picture

Hi Keirl,

could you give me more details about how it was solved.Because i'm facing the same issue exactly but i'm using one appliance 5220 and i tried this on more than one account and i get the same issue.

 

Your support is really will be appreciated

KeirL's picture

Hi Rami

How far have you got?

first putty into the appliance and >Manage >Fibrechannel >Scan

then > Manage >Storage >Scan

then >Manage >Storage>Show

If your zoning and LUN presentation is correct you should see the datastores - if you see nothing new then you first need to ensure you've zoned the datastores with the FC ports on the Appliance. And then present the datastore LUN to the appiance (in my case this was on an HP EVA so I did this with Command View). Remember that multipathing support is not yet qualified for this so I only had a single path to each datastore. Also make sure you're not trying to use the same FC port for Tape presentation on the Appliance (it's an Either\Or option).

Until you can see the datastores from the >Manage >Storage> Show you'll not be able to do SAN transport for the VMs. Once you can see them, then that's all you need to do from a preconfiguration perspective. The rest is just configuring the vcentre server credentials and backup policy.

hope this helps

K