Video Screencast Help

Help with Robotic Tape Library after upgrading to BE 2012

Created: 24 Jan 2013 | 15 comments

Hi all,

So I recnetly upgraded from BE 2010 R3 to BE 2012 and things have not gone as smoothly as I was hoping.  We are using an IBM TS3100 Robotic Tape Library with 2x drives.

Firstly, I keep getting errors/emails as follows:

(Server: "OURSERVER") Library Expansion Option Violation. This server is licensed to support 0 tape drives in robotic libraries. However, the number of tape drives currently in use exceeds the license. You must purchase additional Library Expansion Options, or disable 1 tape drive. Please refer to product documentation for more information.

We had no such errors with 2010, so what am I missing?

Secondly, backups ran last night but a couple failed with the error:  

e0008821 - Job was recovered as a result of Backup Exec RPC service starting. No user action is required.

This is the same error I was having with 2010 R3, so I thought I better bring everything up-to-date before I asked for further help on this error.

Thirdly, since my backups ran last night, the job that failed is reporting that the tape is still in the drive.  I have used the library web gui to move the tape from the drive back into an empty slot, but no matter what I do to BE (restarting the server/restarting services etc) the drive still says that is active and has a tape in it.

Fourthly (if thats a word), as a result of the above point I thought that I would try to reconfigure my tape library settings/drivers etc.  I have ended up with the 2 x drives (one still showing as active/in use even though its not) but it does not seem to have detected the robotic tape library and I have no way to view the 'slots'.

Its a shame that the migration was not partiularly smooth!

Comments 15 CommentsJump to latest comment

CraigV's picture


Error 1

You should have an extra Library Expansion Option license for the 2nd drive. If you don't then you need to apply for 1 otherwise you'll get errors and the drive won't be used. The TN below refers to BE 2010 but it would be the same with BE 2012:

Error 2

The RAWS agent stops causing that error. Check and make sure that no AV installed on the affected server is perhaps blocking the RAWS agent from running. If so, put in an exclusion for beremote.exe. If not, consider uninstalling and then reinstalling the RAWS agent!

Error 3

Try to Pause/Unpause the server: Storage --> right-click library --> Pause. Repeat & Unpause

Error 4

As above...but also check and make sure that BE sees the robotics in Device Manager (should show as Unknown Medium Changer), and that the Symantec drivers are used for the tape drives.


Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

Thanks for your help.

Error 1 - After speaking with Symantec I was able to get them to send me a 2012 version of the LEO license license.  Its just a shame that this was not sent to me at the same time as my server license, it would have saved a lot of confusion!

This now looks to be resolved.

Error 2 - I will try to add an exclusion to the AV, but I am not convinced that is the answer.  The server that I am having the error on has 5 drives.  One night I back up 3 of these drives, the next night I backup the other 2 drives and this schedule continues.  The backups start at around 11pm and the first two will fail with the e0008821 error.  Then the 3rd backup will run at around 3am and that will work ok without the error.  As I say, these are on the same server so I am not convinced it is an AV issue.  Its like it almost has to run a job, have the error and then the next job (on the same server) will be OK.

Error 3 & 4 - I managed to get this resolved by powering down the tape library, shuting down the media server, powering up the library and then powering up the server.  I think the problem was that I did not have the 'unknown medium changer' listed in device manager.  After doing this prcedure it was detected and my robotic library was useable again

So its just the e0008821 error i am still suffering with.

CraigV's picture

On #2, have you tried to run the backup of that server as 1 job to see if you get the same error? What type of server is it, and are there any application maintenance tasks that run during the failed backup run?

Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

The reason I have it as a few different jobs backing up different drives on the same server is because I have 2 drives in my robotic library and had presumed that if I set the backup as 1 big job, it wouldnt use both drives.  Am I incorrect in thinking this?

The server is Win 2008 and runs Veeam backup.  I am trying to backup to tape (to get them offsite) the .vrb/ vbk that Veeam creates.

It could be possible that Veeam is doing its thing at the same time backup exec is trying to do its thing.  could that cause a problem?

VJware's picture

Possibly yes. Here is a KB outlining most common reasons for this error ~

Including "Schedule the job to run at another time to rule out possible third party application interference. Any applications that utilize Volume Shadow Copy will cause a conflict with Backup Exec and may have to be temporarily disabled during the backup window, or removed from the server."

CraigV's picture

Both applications use snapshots...

On my old outsource team, Veeam always ran first followed by a BE backup about 30 minutes later. Reschedule the BE job and see if this affects it.


Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

Ok thanks, i will look into trying to run my jobs at different times.  Can you confirm that it should not be a problem to run 2 jobs on the same server at the same time (to try to utilize the 2 x drives)?

I also have a new problem since installing BE 2012.  When the job fails overnight, it switches the library/drives to 'offline'.  If i switch them back to online, the drive keeps thinking that the tape that was instaleld when it failed is still in the drive and active.

If I use the tape library's web interface to move the tape out of the drive and back into a slot, BE still reports it as in the drive.  Stopping/starting the services doesnt get it back to normal either, the only thing that seems to is:

Powering of the library

Shutdown server

Powering up the library

Powerup the server

Very annoying!  Is there anything I can do about this?

CraigV's picture

...if you stagger the start times there shouldn't be an issue with it.

BE will report it in the drive if you use the library's web interface to interact with the library. BE has no knowledge of what is being done as a result...

Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

I understand that, but what else can I do other than use the libary's web interface to move the disc.  BE was giving me no useful options.

CraigV's picture

If the comms have stalled between BE and the library causing it to go offline, then the tape normally gets stuck. BE doesn't have any ability to move a tape between drive and slots, or between slots...this is a function of the library only.

In this case, if you do so, you need to restart the BE services and run a Scan or Inventory on the library so that BE is aware of where the tape now is.


Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

Ok thankyou.  I have rescheduled my jobs tonight so that they hopefully run after Veeam has finished backing up.

FIngers crossed!

twshelpdesk's picture

Just wondered....

If my backups fail again over the weekend and its due to both Veeam and Backup trying to use 'Snapshot Technology', can I disable snapshot technology  on my BE jobs?

After all, I am only backing up files in a shared drive, I am not trying to take a snapshot of the whole system.

CraigV's picture

Nope, both use VSS...although in BE you can choose your VSS provider.

Alternative ways to access Backup Exec Technical Support:

twshelpdesk's picture

Well things are looking more promising by running my jobs later at night to avoid the Veeam backups.

I will keep an eye on things over the coming days and see if this was the problem.

Thanks all

twshelpdesk's picture

Everything seems Ok now, looks like it was the Veaam & Backup exec backups were not happy running at the same time.  

After adjusting timings so that all Veeam backups had finished and then backup exec timing started, this fixed the problem.

Thanks for all your help