Video Screencast Help

Helpdesk Solution Problems

Created: 01 Jul 2011 • Updated: 03 Jul 2011 | 5 comments
This issue has been solved. See solution.

Hello,

 

I am having problems getting my helpdesk solution to come back up.  Earlier in the day we had incidents of emails not coming to us and I had restarted the server that housed the database and now the server that hosted our web console.  The helpdesk solution page will not appear for any user nor can I get into the Administration part of the page.  All through the logs it appears that the day has come and passed without us knowing.  That could have been the reason why emails were not going through at first and why the helpdesk will not come up at all.  Is there a way to get in to see if our licenses have indeed expired?  If any information can be given about this it would be greatly appreciated.

Comments 5 CommentsJump to latest comment

Rob Moore's picture

Essentially you need to re-run the setup to re-esablish the connection from the server to the DB.

 

Before you do that, a few questions - 

Are you getting any specific error? or is the page just not showing?

Are you sure the service account you are using is not locked out, and that the password you are using is correct?

Do the logs show any errors? 

Are all the Services running? Including the WWW service and IIS Admin service?

 

As for you licenses, they are just certificates stored in the computer certificate store. You can look in there and see if any of your certs are expired.

 

rob

hawkster78's picture

The answers to your questions are

1. When I double click on the helpdesk console it comes up

Error using Helpdesk

Altiris Helpdesk Solution must be installed to use this console

2.  I have checked out the account being used which is our network administrator account which is not locked.

3.  The logs do show errors.  Log File Name: C:\Program Files\Altiris\Notification Server\Logs\a.log
Priority: 2
Date: 07/03/2011 9:22:03 PM
Tick Count: 150608562
Host Name: (The altirs server name)
Process: w3wp.exe (5564)
Thread ID: 3272
Module: AltirisNativeHelper.dll
Source: AlertManager.Configuration.AutoConfigure.GetLicenseDetails
Description: Unable to retrieve license information.
Error: The type initializer for "Altiris.NS.ItemManagement.Item" threw an exception.
<License error="true" SolutionGuid="c432b710-f971-11a2-8643-20105bf409af" SolutionName="" Trial="False" Status="Unlicensed" Available="10000000" InUse="0" DaysRemaining="0" />
   at Altiris.NS.ItemManagement.Item.GetItem(Guid itemGuid)
   at Altiris.Helpdesk.Services.Configuration.GetLicenseDetails(String solutionGuid)

4. The services are running and I even restarted them multiple times.  I even made sure the password for the account that was being used to log on was correct.

 

As for the certificates I tried looking everywhere but cant find the certificate name.  I figured by the log file that the license has expired as it says days remainig = 0   

 

Thanks for your reply and hope to hear back with some sort of solution.  Happy 4th!

Rob Moore's picture

becuse it does not think the helpdesk is configured.

 

If you want to see the license, Open MMC

Add the Certificates Snap in and choose the Local Computer. You'll nee a node called Altiris Licensing.

Expiration dates are listed on the right. you have to open each one to see what it aplies to - It's one of the critial extensions (should be number 1.2.36.xxx or something like that).

 

Can you access the NS console at all? not the help desk, but the actual NS console?

If so, you can try re-establishing the helpdesk. Go to the Configuration Page, then Server Settings -> Notification Server Settings -> Incident Settings and Apply the settings. That should re-establish the connection to the Incindents DB.

 

Otherwise - as a last resort, you can  try this page, it runs through the "installation" again. it should retain all your settings

http://localhost/Altiris/NS/Install/NSSetup.aspx

 

Good luck, and let me know how it turns out.

Have a happy fourth!

Rob

hawkster78's picture

I added the mmc snap in as you suggested and I see three certs that have all expired.  One was in 2008 then one in 2009 and one in 2010.  THey all had the same critical extension when I further looked into them. 

 

When I try to access the NS console I get this as well as when I try to go to that link you suggested. 

 

If im looking at something wrong then feel free to answer back.  Thank you for the suggestions and if there are anymore I'm willing to try.  Thanks.

 
 
Server Error in '/Altiris/NS' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /Altiris/NS/Install/NSSetup.aspx

Version Information: Microsoft .NET Framework Version:1.1.4322.2443; ASP.NET Version:1.1.4322.2470

Rob Moore's picture

Well, without loggin in to you system (which we could do it you wanted - over Go To Meeting - I have an account) the last thing you can do is run a repair on the Notification Server MSI and the latest KB or Service Pack.

You need to get the console up first, then the helpdesk should come up as well.

 

I am free for the next few hours, so email me directly if you want to try the GTM.

 

Rob

rob.moore@travelport.com

SOLUTION