Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How to allow applications to access internet, SEP Ver12.?

Created: 19 Jan 2013 • Updated: 19 Jan 2013 | 9 comments

Good morning.

I have SEP Ver.12.1.1101.

I have a few applications on my PC that are not able to access the internet. When I run them I do not get them popup window from SEP that autodetects that the app. is trying to access the internet and says basically "allow access, yes/no"? I've been looking through SEP to see how to fix this, but so far I do not see the issue.

Can anyone point me to a "how-to" video or an instructional? I haven't seen anything other than a video from 2010 with a different version of SEP.

Thanks in advance!

Comments 9 CommentsJump to latest comment

Ashish-Sharma's picture

HI,

Are u using managed sep client or unmanged client ?

please share popup error screen shot ?

Thanks In Advance

Ashish Sharma

.Brian's picture

Assuming you mean the Network Application Monitoring feature, you can go into the Clients page on the SEPM and it should be on the Policies tab. You can go into and set the option that you need.

Is this a managed or unmananged version?

Symantec Endpoint Protection states that "an application has changed since the last time you used it."

Article:TECH123331  |  Created: 2010-01-18  |  Updated: 2013-01-10  |  Article URL http://www.symantec.com/docs/TECH123331
 

If on the unmanaged client, open the GUI and select Options next to Network Threat Protection

Than select Change Settings

On the Firewall tab, uncheck Enable Network application monitoring

Click OK

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Jack Oneille's picture

It's the unmanaged version.

The popup I believe I should be getting should be "______ program is trying to access the internet, allow/deny access?" with "allow", "deny" and cancel", which I'm not getting, so a few of my programs are failing to connect and sitting there until they time out.

I thought I would have to provide an exemption in the Firewall as well, no?

Also, Enable Network Application Monitoring was already unchecked.

Jack Oneille's picture

Edited.....Duplicate post......I haven't had my coffee yet this morning.

.Brian's picture

Ok, you have 2 options I believe.

1st Option

Enable Network application monitoring and try to use one of the apps that is not working. Once it doesn't work, go back into Options under NTP and select View Application Settings. You should now see the app in here and you can then select Configure and set it to Allow or whatever you need.

You can also select View Network Activity. This will bring up a new box and you can right click on an executable and allow as well.

2nd Option

Go into Options under NTP and select Configure Firewall Rules

Click Add

Add the Rule Name, Set it to allow traffic

On the Applications tab, add the executable for the app you want to access the Internet.

Either of these options should work for you but it's up to you on which you want to utilise.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Jack Oneille's picture

Thanks for the help Brian. I started with Option 1, and to my surprise the programs I am having issues with all have "Allow" checked. So that's why I am not getting the popup, I've already given them access.

I may have more going on with those programs other than SEP than I thought.

Thanks again for the help.

SebastianZ's picture

Some more information to firewall rules on unmanaged clients :

http://www.symantec.com/docs/TECH105725

Can you confirm if disabling the Firewall on SEP allows the programs to connect to internet without issues?

Ashish-Sharma's picture

Hi,

Try to this

To configure application-specific settings

1 In the client, in the sidebar, click Status.

2 Beside Network Threat Protection, click Options > View Applications List.

3 In the View Applications List dialog box, select the application you want to

configure, and then click Configure.

4 In the Configure Application Settings dialog box, in the Trusted IPs for the

application field, type an IP address or an IP range.

5 In the Remote server ports or Local ports group boxes, select a TCP or a UDP

port.

6 To specify the direction of the traffic, click one or both of the following items:

Managing Network Threat Protection

Configuring application-specific settings

■ outbound traffic, click Allowoutgoing connections.

■ To allow inbound traffic, click Allow incoming connections.

7 To apply the rule when the screen saver runs, click Allow while screen saver

is activated.

8 To set up a schedule when the restrictions are or are not in effect, click Enable

scheduling.

9 Select one of the following items:

■ To specify the time when the restrictions are in effect, click During the

period below.

■ To specify the time when the restrictions are not in effect, click Excluding

the period below.

10 Set up the schedule.

11 Click OK.

12 In the View Applications List dialog box, to change the action, right-click the

application, and then click Allow, Ask, or Block.

13 Click OK

Check client Guide Page no 122 -123

AttachmentSize
client_guide.pdf 2.17 MB

Thanks In Advance

Ashish Sharma

Jack Oneille's picture

Thanks everyone for their help. Now that I know that SEP isn't the issue, I've been able to delve into my programs and so far have been able to get 2 of the 3 running in the last few minutes. Checking to see if the program is allowed to run or not is a big help, but so far it looks like the hangups are all due to issues with the programs updaters.

Thanks again!