Video Screencast Help

How to configure the Backup Exec Oracle Agent - Practical Step by Step Instructions

Created: 01 Mar 2008 • Updated: 21 May 2010 | 8 comments
This issue has been solved. See solution.

Hi All,

I had a few problems with this, even after a support call, so I thought I would publish a detailed "click-here", "click-there" how-to article.

1.       First, this should work for at least versions 11d and 12 since I did this on version 12 and compared it to a version 11d installation. I cannot verify that it will work for any other versions. This should also work for DB2 by substituting the DB2 component where I mention an Oracle component since they appear to configure the exact same way, but again, I could not verify this with certainty since I do not have a DB2 database.

2.       Start the “Backup Exec Remote Agent Utility” from the “Backup Exec for Windows Servers” start menu group or if the shortcut is missing, from “c:\Program Files\Symantec\Backup Exec\vxmon.exe”.

3.       On the “Status” tab, check the “Start the Remote Agent Utility every time you log on” check box.

4.       On the “Publishing” tab, check the “Enable the Remote Agent to publish information to the media servers in the list” check box. Click “add” and add the media server IP address or server name. Assuming that your main Backup Exec application is on that server, I recommend using the local host IP address (127.0.0.1) for ease since you would never have to change it if you later change the server name or IP address. NOTE: The definition of Symantec term “media server” is the server where the main Backup Exec services reside.

5.       On the “Oracle” tab, click new, and select the “instance” you wish to backup. The user name here should be the Oracle “SYS” user and the proper password. Enter the media server IP address or server name. Again, I recommend using the local host IP address, 127.0.0.1. This user will correspond to the user we will create later during step 7 in the main program in “Network>Logon Accounts”.

6.       On the “Database Access” tab, check the “Enable media server authentication for Oracle and DB2 operations” check box. Enter the user as Domain\Administrator and click the “Change password” button and set the proper password for the Domain\Administrator account. This user will correspond to the user we will create later during step 8 in the main program in “Tools>Options>Oracle>Modify List”. Check the “Use the full computer name or IP address for Oracle and DB2 operations” check box. Enter the “Name or IP address” of the Oracle Server. Again, since our Oracle was on that server, I used the local host IP address, 127.0.0.1. NOTE: The documentation states that whatever you filled in here to backup, you must use the same exact value to restore. If you use the server name to back up, you will need to use the server name to restore, etc.

7.       Go to the main Backup Exec for Windows Servers program. Go to the menu item “Network>Logon Accounts” and click “New”. Add the Oracle user “SYS” with the proper password and hit “OK”. This needs to match the user you created in Step 5 on the “Oracle” tab. If it does not exist, also add the Domain\Administrator user also and set it as default by clicking the “Set as default” button to the right. Add this user even if “System Logon Account” already exists since they need to match the format exactly with the user you entered in the “Database Access” tab of the “Backup Exec Remote Agent Utility” per the Symantec/VERITAS support article 292442.

8.       Go to the menu item “Tools>Options>Oracle>Modify List” and click “New”. Add the IP address of the Oracle Server and pick the Domain\Administrator account from the “Logon Account” drop-down box and hit “OK”. This needs to match the user you created in Step 6 on the “Database access” tab. Again, I used the local host IP address, 127.0.0.1, since our Oracle database is on the same server as the Backup Exec. All the information you entered here should correspond to the information you entered in the “Database Access” tab.

9.       You should now be able to select your Oracle database as a backup resource. You should also check the credentials for your job by going to the “Job Setup” tab and double-clicking any backup selections you have in the “Backup Selection Lists” pane, then going to the “Resource Credentials” in the left pane, and then hit “Test All”. The computer level at the top should use the Domain\Administrator account, the rest will inherit from that, with the exception of the “Oracle Database”, which should be using the SYS account we created in step 7. If not, highlight it and click “Change” on the right side.

Other common problems include the database needing to be placed in “automatic archive log mode” as described in Symantec/VERITAS support article 266835; and the need to change the “Archive Log Mode” from “NOARCHIVE LOG” to “ARCHIVE LOG” (in version 9, in the Oracle Enterprise Manager Console, go to “Network>Databases>DatabaseName>Instance>Configuration” and then to the “Recovery” tab, and check “Archive Log Mode” box. This needs to be done as the Oracle SYS user and this can be changed in “Configuration>Edit Local Preferred Credentials” if necessary.

 

KEYWORDS: 0xe0001403; 0xe0001014; “Failed to access Oracle database”; “Cannot start an Oracle session. Check that the logon credentials are correct, and have sufficient privileges.”; “The database is in NOARCHIVELOG mode and is OPEN. To back up the database when it is in NOARCHIVELOG mode, the database must be MOUNTED but not OPEN.”

Relevant Symantec/VERITAS support articles regarding common errors, setup, backup, and restoration using the Oracle agent: 266835; 292497; 292442; 300135; 300134; 300133; 300130; 300119; 300125; 300123; 300118; 300116.

You may also go to this page for a complete list of Backup Exec for Windows Server support articles, including those regarding the Oracle agent: http://seer.entsupport.symantec.com/docs/BEWNT_index.htm.

 

Best Regards,

Kevin Cotreau
MCSE+I, MCNE, et al.

 

Comments 8 CommentsJump to latest comment

whiskey6's picture


Hi there, I have Oracle 11g running on FC7. I have also installed the ralus backup agent on said server so that it can communicate with my backup server, which is running server 2008 and the latest veritas. I want to be able to backup oracle via Veritas. When I tried to do so, I was told to run 'vxmon.exe' in order to configure the oracle backuperator(Backup exec oracle agent configuration). However, when I try to connect to the Oracle server, I keep getting an 'Invalid Oracle SID Name'

Any ideas?

Thanks!

whiskey6's picture

So what I ended up doing is logging into the Oracle manager and configuring a backup job from there. It would dump into /oracle at 1am. At 2am iptables shuts down, the backup exec goes in, grabs the file. at 3am iptables fires backup again.

Perhaps I should start a thread about what IPtables rules I should allow?

Anyways, thanks to Kevin for the help :)

Andrey Karmadanov's picture

Kevin,

 

Thank you for such a detailed instauction. It is really helpful. Let me just add one more and very small thing:

Before creating a backup job on Backup EXEC console you have to add Domain\Administrator user (you mentioned in you instruction) to ORA_DBA local group on the Oracle DB server

 

Thanks again,

Andrew

Kevin Cotreau's picture

Andrey, that must have been there by default then for me since I did not have to make such a change. Thank you for the addition and hopefully it will help someone if they do run into a problem.

 

Looking at the number of views, I am really glad my original post has helped a lot of people.

Mike Ely's picture

Be nice to see such a post for people running their Oracle servers on Linux (hardly a rare occurrence).  Am fighting with the dreaded 0xe0001403 error on mine.