Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

how to configure SAN client with SAN media server in netbackup 7.1

Created: 23 Aug 2012 • Updated: 19 Sep 2014 | 22 comments
NBU_13's picture
This issue has been solved. See solution.

Hi,

 

Anyone please guide me and If you have any configure information, please share with me.
 
I have one query, in this SAN configuration, drives need to configure directly with SAN media server with SAN media server license, with SSO and tape drive library license,
 
for SAN client, we need SAN client license, my question is, we need to zone and configure tape drives on each SAN client or only on SAN media server ?
 
SAN media server is windows, so we need to zoning drives with SAN media server ?

what are the basic requirement configuration to do for SAN media and Client configuration.
 
Please guide me on this query and also share configure documents.

Comments 22 CommentsJump to latest comment

Mark_Solutions's picture

SAN Media Server / SAN Client / Enterprise Client are all one and the same these days.

A SAN Media Server can only back itself up - it is not permitted to back up other clients - this is now known as a SAN Client or an Enterprise Client

Any "SAN" client will need to see the tape drives as it has to write its backups directly to tape that it can see.

If you have several then each of them will need to be zoned to see the drives.

One drive license per drive, one SSO per drive so if you have a 6 drive library you just need 6 of each no matter how many servers share them

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

Please do not confuse SAN Media server and SAN Client.

You need a 'full' (Enterprise) media server in order to backup a SAN Client. Only Solaris and Linux Media servers are supported as FT Media servers.

A SAN Media server is installed with Media Server software and will backup itself to SAN attached media.

see: http://www.symantec.com/docs/TECH135896 and http://www.symantec.com/docs/TECH53815

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

NBU_13's picture

Hi,

Today I try to configure SAN client and FT media server,

I started pbx and FT service in SAN client, Now I can able to see SAN client in master server´s SAN client list, then I try to configure FT media server, which is tape library is directory connected with media server through Fiber cable.

I tried to excute below command, but I got error message

[root@media8stgo admincmd]# ./nbhba -l
Unable to communicate with HBA ports.
Please ensure that this system is set up correctly with nbftsrv_config.
(Must not be set up as FT Server.)
Error #11: system call failed

[root@media8stgo admincmd]# ./nbftsrv_config -nbhba

Installing nbhba driver.
There is no driver at /usr/openv/netbackup/bin/driver/ql2300_stub.ko.2.6.18-308.11.1.el5 to install.
Your operating system version (2.6.18-308.11.1.el5) may not be supported.

[root@media8stgo admincmd]# ./nbftsrv_config

Installing the Jungo WinDriver and Fibre Transport Server.
There is no driver at /usr/openv/netbackup/bin/driver/windrvr6.ko.2.6.18-308.11.1.el5 to install.
Your operating system version (2.6.18-308.11.1.el5) may not be supported.

 

Error logs,

23-Aug-12 15:09 - requesting resource media8stgo-hcart2-robot-tld-8
23-Aug-12 15:09 - requesting resource masterstgo.NBU_CLIENT.MAXJOBS.solman-nw7
23-Aug-12 15:09 - requesting resource masterstgo.NBU_POLICY.MAXJOBS.GlobalCrossing-solmannw7-FS
23-Aug-12 15:09 - awaiting resource media8stgo-hcart2-robot-tld-8 - FT client has no devices configured
23-Aug-12 15:09 - granted resource masterstgo.NBU_CLIENT.MAXJOBS.solman-nw7
23-Aug-12 15:09 - granted resource masterstgo.NBU_POLICY.MAXJOBS.GlobalCrossing-solmannw7-FS

 

So I created soft link between blow files and exist files in /usr/openv/netbackup/bin/driver

ql2300_stub.ko.2.6.18-308.11.1.el5

windrvr6.ko.2.6.18-308.11.1.el5

 

and then I excute command below command

[root@media8stgo admincmd]# ./nbhba -l
 

it show 1 hba card with WWN

then I excute command below command

[root@media8stgo admincmd]# ./nbftsrv_config -nbhba

and

[root@media8stgo admincmd]# ./nbftsrv_config

I configured that one HBA card and started FT service in Media server, media server is Linux, So It ask to reboot the server, So I rebooted, but after reboot server not came online.

 

Can anyone help me on this issue, its very urgent, because media server is production server.

 

Thanks in Advanced

Gavrilov's picture

Try to boot into rescue mode from DVD or LAN then mount your /usr or /opt partition (depends on your configuration) and remove created  symlink. What Linux version you're running?

Cheers,

Mike

sazz.'s picture

Oops! I was going through the threads and found this, seems all of us overlooked it.

I hope your system is up by now.This might have happened due to the drivers that you have installed. Try to rollbackup asap.

NBU_13's picture

Now, Iam explain clearly,

I have media server with 2 tape drives connected directly through fiber cable and I have 10 clients are connected with SAN switch via fiber cable and SAN switch is connected with media server via fiber cable, Now I want to configure media server as FT media server and 10 clients as SAN clients,

Question 1 : FT media server is directly connect with Library, so zoning is not need, but 10 SAN clients are connected with SAN switch, now, I need to do zoing 10 SAN clients with FT media server or tabe library ?

Question 2 : I have HBA card LQ2460 in FT media server, can you tell me, this will support this environment? how can i install LQ2460 driver software in Linux system ?

can anyone guide me on this query.

Gavrilov's picture

Q1: Q1: You need to create zone with  FT-server's HBA ports that are in "target mode" and clients. But make sure that you have calculated your throughput right.

Q2: http://www.symantec.com/business/support/resources...

Did you mean QL2460?  24xx is supported.

 

Cheers,

Mike

NBU_13's picture

yes, QLogic 2460 HBA will support FT media server ?

Gavrilov's picture

According HCL - yes.

In older SAN-client guide I've found:

The Fibre Transport Server requires at least one QLogic 2340, 2342, 2344, 2460, 2462, or 2472 Fibre Channel Host Bus Adapter

So, it should work.

Cheers,

Mike

NBU_13's picture

ok, thanks for confirmation,

But, while I try to configure for FT media server, it gives error message as below.

[root@media8stgo admincmd]# ./nbhba -l
Unable to communicate with HBA ports.
Please ensure that this system is set up correctly with nbftsrv_config.
(Must not be set up as FT Server.)
Error #11: system call failed

[root@media8stgo admincmd]# ./nbftsrv_config -nbhba

Installing nbhba driver.
There is no driver at /usr/openv/netbackup/bin/driver/ql2300_stub.ko.2.6.18-308.11.1.el5 to install.
Your operating system version (2.6.18-308.11.1.el5) may not be supported.

 

 

Gavrilov's picture

What Linux distribution you are running? What version? Do you have any HBA moduls loaded?

#lsmod | egrep -i 'lp|ql'

What do you have in this folder?

#ls -la /usr/openv/netbackup/bin/driver/

What NBU version you're exaclty at?

#cat /usr/openv/netbackup/bin/version

What happend to system then you tried to apply this solution?http://www.symantec.com/business/support/index?page=content&id=TECH72795  As I understand you managed to fix it after non-bootable state.

Cheers,

Mike

NBU_13's picture

But, in latest, symantec Netbackup Enterprise server and server 7.x Hardware campatibility list, Created on August 22, 2012, mention like as below, they didnt mention QLA2460,

 

QLogic - Windows / Linux :

2. Requires NetBackup 7.1 or later.

3. Fibre Transport Media Server is only supported with the QLA2340, QLA2342, and QLA2344 members of this family.

4. Red Hat Enterprise Linux 4 requires Update 3 for the Fibre Transport target mode driver. Other Updates of Red Hat EL 4 will not allow the target mode driver to be

used with the host bus adapter.

 

QLogic - UNIX

2. Requires NetBackup 7.1 or later.

3. Fibre Transport Media Server is only supported with the QLA2340, QLA2342, and QLA2344 members of this family.

 

Gavrilov's picture

SANblade 24xx series -- is still in place.

Cheers,

Mike

NBU_13's picture

Hi mike,

I follow the same link, which you have pasted,

http://www.symantec.com/business/support/index?page=content&id=TECH72795

 

So I created soft link between blow files and exist files in /usr/openv/netbackup/bin/driver

ql2300_stub.ko.2.6.18-308.11.1.el5

windrvr6.ko.2.6.18-308.11.1.el5

After that, I configure nbhba and it ask reboot, I rebooted, it went down, not came up,

that is the issue, I raised call with Linux Engineer and they came to site and they make server back to online, but they told, there is some changes happended in kernal,

Now, I dont have answer to give to system Engineer. 

 

my server is Linux version 5, I have QL2460 HBA card, and 2 drives are directly connect with media server through fiber cable, 

can anyone give the step to configure the FT media server in this environment.

Gavrilov's picture

Well, we know how to deal with "There is no driver at /usr/openv/netbackup/bin/driver/windrvr6.ko.2.6.18-308.11.1.el5 to install"  but if  your symlink  was  a root cause of your problem it isn't a good idea to create it again. It doesn't mean that your HBA doesn't support, it just means that current driver doesn't match curent kernal version. Can you ask your  Linux Eng what exactly   happend to system and if your symlink was involved?

I asked you about your system above could you  please answer?

>my server is Linux version 5 - Is it RHEL 5 or CentOS or somthing else?

Cheers,

Mike

Gavrilov's picture

1. First of all you can upgarde your NBU up to  7.1.0.4 cause it has a lot of patches + EEB Boundle for SAN-client.

2. If you really know that symlink wasn't a problem you can repeat solution with symlink.

Cheers,

Mike

NBU_13's picture

ok, thanks Martin,

Now, Client have new requirement,

I have 1 media server (Redhat Linux , version 5) is directed connected with 2 tape drives via fiber cable and I have 10 clients, which are connected to media server with fiber cable via SAN switch and also I have 15 clients which is connected to same media server(Redhat Linux , version 5) with LAN cable, Now, I planned to configure this media server as FT media server to take backup of 10 SAN clients and also I want to use this same media server for 15 clients, which is connecte via LAN cable.

question 1 : I can able to take SAN clients and LAN clients backup to same FT media server? if YES, can you please what and where I need to configuration.

question 2 : SAN clients are connected to FT media server via SAN switch and tape drives are directly connected with FT media server via fiber cable, Now If I want to do zoning SAN clients with FT media server or Tape rives to take SAN clients backup ?

Please advice me on this query.

Thanks in Advanced.

Gavrilov's picture

A1: Yes, you can. Configure both SAN and LAN clients as usual to use STU created on Library connected to the media-servver. Clients who configured as a FT-clients will just use another transport. SAN Client and Fibre Transport Guide is pretty enough.

A2: You need to create zone included "clients+ Media server's HBA port in target mode". That's all.

Cheers,

Mike

SOLUTION