Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

How to delete restored System State in alternate location

Created: 02 Nov 2012 • Updated: 14 Feb 2013 | 10 comments
wilsonchong's picture
This issue has been solved. See solution.

Hi,

We did a backup of ALL_LOCAL_DRIVE for a Windows 2008 R2 machine running NBU 7.1 and did a restore test on the data drive D: . We found out some of the exe file is not being restore and after google found out is due to the files are filtered in the Shadow Copy Components from the TN76997.

So we did a restore of the System State to an alternate location, which is the D:\Restore folder, and we managed to see the exe file is inside the System State -> System Files folder in the restore folder.

The problem now is when we tried to delete away the D:\Restore folder, we are not able to do it and always got the Access Denied error. I did try to use the "takeown" and "cacls" to take the ownership and grant the permission for the folder in a command prompt. But when delete the folder using "rmdir" or "del" still got the Access Denied error.

Hope can get some advise from here and what should be the correct way to restore a data drive, which have files filtered in the Shadow Copy Components.

Regards,

Wilson

 

Comments 10 CommentsJump to latest comment

Nicolai's picture

When you opned the dos box, did you right click choose "Run as administrator" ?

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

wilsonchong's picture

My account is Administrator account. I also tried "Run as administrator", same results.

Yasuhisa Ishikawa's picture

Have you tried to remove system file flag by attr command?

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

mandyc's picture

I also have this problem...I tried "Run as administrator"...no lucks...tried to attrib -s but it shows access denied to change attrib...

any clues?

Marianne's picture

This is really a MS Windows issue, not NBU. 

Maybe best to ask in a Microsoft forum?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Yasuhisa Ishikawa's picture

Try to change owner of files and folders to administrator. I can remove all the files on my lab machine.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

mandyc's picture

hm...finally...we made it...we tried to change owner as well, but it could not solve the problem...

we finally... un-hide the hidden folders and files, then remove SYSTEM from permission of those trouble files/folders, after that, add everyone with full control permission (i dunno why administrators with full control permission could not do the work...strange...) and then all can be removed...

Yasuhisa Ishikawa's picture

un-hide the hidden folders and files

Yes, some additional tasks like unhide and permission change are needed.
Unfortunately I'm working with Japanese Windows, so I can't provide detail in English.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Yasuhisa Ishikawa's picture

Please have a look on this. I could remove System State files restored to C:\restore.

https://www-secure.symantec.com/connect/blogs/how-remove-files-can-not-remove-you-require-permission-trustedinstaller-windows-server-2008

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION