Video Screencast Help

how to delsec rvg when the primary is unknown?

Created: 11 Dec 2013 • Updated: 12 Dec 2013 | 9 comments
This issue has been solved. See solution.

i am on the secondary of a rvg. but the primary is not connected. 

how can i remove the rvg stuff?

i tried 

vradmin -g $dg -f delsec $rvg

but it gave me this error:

VxVM VVR vradmin ERROR V-5-52-449 Secondary $rvg does not have an active Primary.
 
Operating Systems:

Comments 9 CommentsJump to latest comment

Gaurav Sangamnerkar's picture

Hi,
Vradmin delsec command won't work if connectivity between primary and secondary is broken

If you want to delete the components still, you can use vxedit command...

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

mikebounds's picture

To delete manually use:

  1. vxrlink det rlinkname
  2. vxvol dis (for all volumes including srl) - you may need to run "vxrvg [-f] stop rvgname" first
  3. Then you can delete rlink and rvg objects using vxedit.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

IdaWong's picture

i am afraid it is not as simple as that. 

i have disabled the rvg. removed the rlink

how can i just remove the volume association without removing the volumes?

mikebounds's picture

use "vxvol -g diskgroup dis vol_name"

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

IdaWong's picture

I tried below but it didn't work:

vxvol -g $dg dis $rvg

but i guess i should have tried to dis the data vol as well.

 

Gaurav Sangamnerkar's picture

Hi,

what is the error you are getting while runing vxvol dis ?  did you stop rvg first using vxrvg stop OR vxrvg -f stop ?

disassociating volume from rvg means you are taking out volume out of RVG. You need to disassociate all the volumes before you can delete the rvg using vxedit command.

You can also try giving a "-f" with vxvol command to force disassociate

vxvol -f -g <diskgroup> dis <volume> <rvg>

 

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

SOLUTION
IdaWong's picture

i have run "vxrvg -g $dg stop $rvg". and the rvg became DISABLED

i have run "vxvol -g $dg dis $rvg" but as you suggested i should probably have run "vxvol -g $dg dis $vol $rvg"

Gaurav Sangamnerkar's picture

After the RVG is disabled, when you ran vxvol -g $dg dis $rvg, did you got any error ?

If yes, paste the error message

Also, try a force option as I suggested above

# vxvol -f -g $dg dis $vol $rvg

 

 

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

IdaWong's picture

there was error reported when running "vxvol -f -g $dg dis $rvg", it complained about the data volume associated.

anyway i can't try any more. i have run "vxedit -g $dg -rf rm $rvg" already.

but next time i would give your method a shot though.