Video Screencast Help

How to disable telemetry feature on the 5020 appliance

Created: 20 Jul 2012 • Updated: 04 Dec 2012 | 7 comments
ddm2's picture
This issue has been solved. See solution.

Hello folk,

I want to disable telemetry feature on the NB 5020 appliance.

How do it?

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

Antonio Martín's picture

There are a e-track with this issue and a binary to fix it:

E-Track 2904199

ddm2's picture

Thanks for your answer.

I solved the problem with the support, but I'm interested in the fix. Can you tell me the link?

Thanks again and have a nice day. 

sdo's picture

FYI - I believe that that ETrack also applies to N5220 before v2.5.1 (i.e. the fix is included as far as I can tell in v2.5.1).

sdo's picture

It only takes a few minutes to cleanup what's there while waiting for the patch to arrive and arranging time to install it:

ls -als /var/symantec/telemetry | head -7

ls -als /var/symantec/telemetry | tail -4

ls -1   /var/symantec/telemetry | wc -l

df -h   /var/symantec/telemetry

date && ls -1 /var/symantec/telemetry | while read line; do rm -Rf /var/symantec/telemetry/${line}; done && date

df -h   /var/symantec/telemetry

ls -1   /var/symantec/telemetry | wc -l

It took about 4 minutes to remove 9000 folders on each of our eight N5020 nodes.

sdo's picture

The ETrack numbers to quote/reference are:

ET2909692 to aquaire EEB fix for N5020 (de-dupe) stale telemetry files left behind.

ET2904199 to acquire EEB fix for N5220 (media servers) stale telemetry files left behind.

Mark_Solutions's picture

OK - for those who haven't yet patched please do it ASAP!

And here is a real easy fix to clear the files down .. based on the telemetry directory only containing the telemetry files - this is assuming that you just want to clear it down and are not concerned with the call home data stored there (after all it will start to recreate it almost immediately!) This was done under the guidance of support so should be OK

As you made have discovered the rm and rmdir don't have all of the functions of the full SUSE versions so just do this:

appliance:/ cd /var/symantec

appliance:/var/symantec rm -rf telemetry/

appliance:/var/symantec mkdir telemetry

All done - now patch! (cleared 40GB of a N5020 yesterday!!)

Also remember that this applies to 1.4.2 and 1.4.3 versions of N5000 and N5020's and 2.0.2, 2.0.3, 2.5 and 2.5.1 versions of N5200 and N5220's

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION