Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How do I boot to PXE server multiple times? 7.1 Issue

Created: 17 Sep 2012 | 8 comments

This has me scratching my head...

If I create a task, to Reboot to a PXE server (x86 or x64), and run it on a particular machine, it will work the first time, and PXE boot properly.

If I run that same task a second time, it reboots, acts like it is going to connect to the PXE server, and then says "Exiting Intel Boot Agent" and then proceeds to boot to Windows.  

The Reboot to PXE server task reports that it was successful, although it obviously was not.

Is there something I am doing wrong?

Thank you.

Comments 8 CommentsJump to latest comment

RufusS's picture

Hi Boonet,

Is the client computer getting an IP Address from DHCP?

Also have you selected to respond to unknown computers or not?

Sachin_Joshi5's picture

Hello boonet,

Which is the build that you are using?

Please check sbslpog_pxe on NBS machine, that will give you an idea what is going wrong.

Also please check if boot to production task is complete & successful.

Since the client is alredy managed, 'respond to unkown computer' is not applicable here.

Thanks,
Sachin

boonet's picture

Hi Sachin.

I am unable to find where this sbslpog_pxe is located.  I have looked in this path, but do not see that file:
D:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\SBS

As for the Boot to Production tasks, it works just fine.  Since my boot order is NIC, and then Hard Drive, it exits the boot agent and continues to boot into Windows.  Boot to Production produces a task of:  100% Succeeded.

Now, if I run the Boot to PXE task, it does the same thing, boots to NIC, says "Altiris", acts like it is going there, and then "Exiting Intel Boot Agent".  The console will then report that the Boot to PXE task was 100% successful, although I can physically look and see that the PC is booted into Windows.

boonet's picture

And here's another interesting piece to this puzzle:

If I go into the Settings and add a new Preboot Configuration, I am able to to use that task (at least once) to successfully PXE boot a machine.  Is there any rhyme or reason for this inconsistency?

Sachin_Joshi5's picture

Ok. Thanks for information.

Can you try to select that partitcular pxe image on Create preboot Configuratin page & recreate it and then re-run the same boot to pxe task(with recreated image). This will help to understand where the problem might be.

Also share setup & build details.

Thanks,
Sachin

Thomas Baird's picture

Try restarting the NETBoot Server service on the PXE server, wait 1 minute, and see if the same system boots correctly the next time.

Also, when you assign a job like that to a system, watch the PXE server to see if an SBS file arrives.  If not, then what you've asked it to do will fail.

IF this ends up being the issue, there may be more we can do, but please note that because of things just like this, we re-architected the next release specifically so it will not run into this issue.

Either way, let us know.  :D

Thomas Baird
Enthusiast for making things better!

 

MJammer's picture

This morning I had to re-create the OS files under Settings>Deploymnet and Migration>OS Files

Put in Name/Description and uploaded the SOURCE directory from the Win 7 DVD in to the Deployment\TaskHandler\SOI directory.

My job for this is:

1. Disk Wipe

2. Disk partition

3. Deploy Windows OS with Deployanywhere checked off.

I swear I re-built the OS Files in the past and it would never work, even if I had x64 set as the architecture for the PXE Boot Image. Guess I had to step away from this for a while.

A side question, is it possible to have a Preboot Configuration built with Architectures x86 and x64 then have intelligence decide which one to use if I want to deploy a x86 OS or x64 OS?

Thomas Baird's picture

replied to on a different thread.

Thomas Baird
Enthusiast for making things better!