Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Cannot find any files to backup on Domain Server 2008-R2

Created: 08 Apr 2013 • Updated: 10 Apr 2013 | 15 comments
jaykay1952's picture

I have 4 Windows Server 2008R2 Domain Controllers with Backup Exec 2010R3. On all of them, I installed the Backup Exec with the System Logon User named BackukpAdmin who is a member of Administrators, Domain Admins, and Backup Operators. On all of them, when I go to add a job, they do not show any local selections that can be backed up. The "All Rescources" is just blank, exactly as is shown in Article ID TECH84628. The article says it is because the default login account does not have the right to "Logon as a Batch Job". But if I follow the instructions in the article and go to the Group Policy for "log on as a Batch Job", it shows that Administrators, Domain Admins, and Backup Operators already have this right. And my user is a member of all 3 of those groups. And during the install, the screen showed that the system account had been granted the right to log on as a batch job. I have also tried having the System Logon user being just an Administrator, and just a Domain Admin. Still the same results. Any ideas?

I really don't understand why they wouldn't just work after installing without doing anything special.  I am using the Operating System and the Backup Software that came together in the box with the servers. It seems like they should just run ok together right out of the box.

 

Operating Systems:

Comments 15 CommentsJump to latest comment

CraigV's picture

...this isn't the QuickStart version is it, which is a severely cut-down version of BE 2010 R3?

Also, are the RAWS agents started up on each remote server, and if you have a firewall, is it disabled or set to allow port 10000 to be open?

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Alex Zn's picture

You should see all resources but may not have access to select them in case of rights insufficiency. To completely exclude rights issue i recommend to run Backup Exec Remote service on the client from domain administrator account if you see the same, than try to temporary disable any firewall between server and client.

jaykay1952's picture

Both of the above replies seem to be about remote backup. I am not doing anything remote. I have a 2008R2 Domain Controller with Backup Exec 2010R3 installed on it and it won't show any resources to backup. I just happen to have 4 new systems all the same, at 4 different offices, with the exact same problem. Nothing is being done remotely.

As for rights, it is hard to see how the system logon account would not have the rights when it is a member of the Administrators and DomainAdmins groups.

Again, I am not running ANYTHING remotely or with a remote agent. I just want to back up the files that are on the server that the Backup Exec is installed on.

Also, before purchase, I was assured by Symantec Tech Support that Backup Exec 2010R3 QuickStart Edition WOULD work to backup Data and Domain on a 2008R2 Domain Controller. I also had replies on this forum from other partners that were using the exact same products successfully on their systems.

So, perhaps we could try this another way. Even if my system logon account has all the rights needed, maybe I still need to do what is described in Article ID TECH84628. But I don't understand where to find the username I am supposed to put in. In the article, it says I am supposed to put in the Backup Exec service account, and they show a name "Test\SQLServer2005MSSQLUserSWIN2K8$BKUPEXEC". I am assuming that the "Test" part would be my domain name, but how do I find out what the rest of it would be for my system? I am not using Windows2000 and I don't know what version of SQL it is using (I know nothing about SQL) so the service name I would have to put in would be different. So how do I find the name that I am supposed to put in here, as the Article TECH84628 wants me to?

CraigV's picture

...not sure on your question about the SQL account, so I will leave that from someone from Symantec's technical team to pick up on that.

That said, QS shouldn't have any issues backing up servers, but can you perhaps try 1 thing and download BE 2010 R3 on the link below. Uninstall QS on your nearest DC and install BE 2010 R3 full in trial mode and see if you get the same issue.

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

I will also hit the escalate button on your query...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Vasilis Peppas's picture

Hi 

 

It sounds like the remote agent on each local computer is not running. Check to see that it has started. Also try looking for the server in the network part of the selection view it should be visible from there as well. If it is try right clicking and establishing a trust relashionship. Remote Agent should be running on the BE server with localsystem and not  BackukpAdmin. As a last suggestion change all the backup exec services to run with "Localsystem"

CraigV's picture

...please read ALL the comments above.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Vasilis Peppas's picture

Actually you do not, You are also asking confirmation that RAWS is running and not stating that it is.( unless there is some hidden post that I cannot see)

 

BR

CraigV's picture

...second line is a mistake and I will edit it out. I did, however, ask if RAWS was running which isn't a hidden post wink

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

PackMatt73's picture

Hi JayKay

I am part of the product management team for BE.  I sent you an email via Connect as I would like to get you connected with an engineer from Tech Support.  My contact info is included in the email.  Please drop me a line at your convenience.

Matt Stephenson

Donald Eady's picture

Hey JayKay, 

 

      I know that you said that the Backup exec service account was a member of Administrators, Domain Admins, and Backup Operators which already have the logon as a batch right. Please go ahead and give this right as well as the following to the BESA account restart all B.E. services and try to browse again. 

Act as part of the operating system
Backup files and directories
Create a token object
Logon as a batch job (All Windows 2008 version only) 
Logon as a service
Manage auditing and security log
Restore files and directories
Take ownership of files and other objects 

Additionally as the document states please verify thatDeny logon as a batch and Deny logon as a service have not been selected.

http://www.symantec.com/docs/TECH23689

I hope this posting was helpful

  

lmosla's picture

Hi JayKay,

Check and install any live updates.  You may need to run and check again a few times to make sure they are all installed.

Also verify that the SQL Server (BKUPEXEC) service logs on as Local System account and is set to automatic startup.

jaykay1952's picture

Thanks to everyone for all of the input. It is Monday, and we have only just gotten power back on after an ice storm knocked it out last Thursday. I have a lot of other customers to get taken care of from this and will not be back at this customer's site until later this week. I will post here what I find out from trying the various items in the various posts.

John

jaykay1952's picture

 So here is the end results. I tried everything everyone suggested and everything I could find on the web, and nothing worked. I have 1 Domain Controller at the main office and 2 RODC controllers at the 2 branches. The problems I was having occured on both the regular domain controller and the RODC controllers. The troubleshooting work was done on both the regular Domain Controller and one of the RODC controllers. So I gave up on the Backup Exec 2010 that we have a license for, and downloaded the trial version of BackupExec 2012 to see if that would work. I started installing it on one of the RODC controllers and the install program said that Symantec Backup Exec cannot install an SQL instance on an RODC, because of the security settings on an RODC server. It said that I would have to install an SQL instance on another server to serve the Backup Exec on the RODC controller.

So can someone explain to me the following;

(1) Why would Backup Exec 2010 install on the RODC's, but not Backup Exec 2012? Don't they both have SQL databases?

(2) Before I even started this project, I called Symantec tech support and asked if I can run Backup Exec on an RODC without any problems and was told yes. I also asked the question on this Symantec forums site, and had multiple people tell me they were using it, and had no problem at all running Backup Exec on an RODC controller. So why am I getting this message?

And again, please note that I had the initial problems with Backup Exec 2010 on ALL of the servers, including the regulad Domain Controller at the main office.

So in the end, I don't understand the rationale of running the SQL instance on another server so that I can run Backup Exec on the RODC. If I had another server, I would just install the Backup Exec on that server. So since I have to come up with a different solution at the branches, I will use the same solution at the main office. I will just be using Microsoft Server Backup at this customer. I am a Symantec reseller, and always use Symantec products. I am just disappointed that Symanted does not have a solution for this.

If anyone has any comments or answers to my 2 questions above, please feel free to comment, as I would be very appreciative of anyone else's opinions or insights. I am also very grateful to all of the people who gave posts to this thread for their help in trying to solve my problem. Thanks to you all.

John

Colin Weaver's picture

When you are checked the Group policy are you using th default group policy or the domain controllers group policy (another default one)?

 

Also I would recommend setting the specific rights on the account itself via the Domain Controllers GPO and not rely on the group link (just in case)