Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

How do I import my keys back into PGP from a backup?

Created: 03 Sep 2011 | 4 comments

Maybe I'm overlooking an obvious answer, but I removed my keys in PGP desktop and I want them back now!  I was fiddling with things, and I know I messed up.  I accidentally create a new key awhile ago and my PGD drives were requiring a passphrase to open when they normally just mount with my key automatically.  So, I pulled the keys out of my backup and thought I could just put them import them into PGP desktop, but I guess it doesn't work like that.  Is there a wayt o import my old keys?  I have the fies:

PGP Private Keyring Backup.skr
PGP Private Keyring.skr
PGP Public Keyring Backup.pkr
PGP Public Keyring.pkr

With these, should I be able to put them back like they used to be?  I am really stuck on this, and it's killing me!

Comments 4 CommentsJump to latest comment

desertrat's picture

I think I've managed to really confuse myself.  Here's what I did.  I found the proper way to export and import keys, but I still have some issues.  I started up my bootable clone which has PGP with my original keys in it.  I exported the keys from there using file>export.  Then, I imported my keys by opening them on my real computer with PGP.  I imported the keys sucessfully, but something isn't working properly.  With my bootable clone, I am able to open my PGP volumes that are set up to open with my keypair by just opening them.  They mount just fine.  Back to the real computer, where I installed the same keys form the working clone, I have to type in a passphrase.  This is the reason I started messing around with this in the first place, because somehow my volumes stopped mounting without a passphrase.  I tried to recover my public key from the global directory, and it appears I may have never actually approved the key to be published, because I can't find it.  But, everythig works fine on my old clone, so I don't understand how to troubleshoot this at all.  I have been reading throught the help files and booting back and forth between machines for 5 hours today, I just don't know what I'm doing wrong.  I hope someone can help!

Edit to add- I just tried publishing the key from the clone.  I don't know how long it takes to be visible, but it didnt happen yet.  Do I have to get an email to confirm the published key before it is visible? 

Edit again-  I finally found that I was missing somethign.  I guess I had my passphrase saved to my keychain, which is what was allowing me to open volumes without typing the passphrase every time.  So, I guess that sort of solves my problem.  We'll see if I run into any other issues!

PGP_Ben's picture

It's possible that you could have been running into this:

http://www.symantec.com/docs/TECH149697

Sometimes you have to manually set trust properties on a key to verified after importing (if it can't be automatically verified)

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

Rzworld's picture

Hello Desertrat,

You can try this :

HOW TO: Import PGP Keys - PGP Desktop 10 for Mac

http://www.symantec.com/docs/HOWTO42072

or

Importing PGP Keys - PGP Desktop 9.x for Mac

http://www.symantec.com/docs/TECH149495

Tom Mc's picture

Is this still a problem for you?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &