Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How do I 'Locate the EMM reason string' for troubleshooting?

Created: 08 Jul 2013 • Updated: 15 Jul 2013 | 12 comments
This issue has been solved. See solution.

I'm having some jobs fail and I need to figure out why. This is a poorly documented environment that I have been floating along since I started back in December. That having been said here is what I DO know:

 

We are doing disk to disk to tape. Back up from the server to a NetApp then offload to tape. The Netapp is/was hardwaired to backup to two specific tape drives (we have 2 libraries with 2 drives each), one tape drive on each library. I had a drive fail (no maintenance, and being junked in a month = no replacement) so I reconfigured everything to backup to the one drive I had left of the two. Now I'm getting this:

 

Status 800: resource request failed

The nbjm process was unable to get the required resources for a job. An EMM reason string that appears in the Activity Monitor job details display and in the nbjm debug log accompanies this status code. The EMM reason string identifies the reason for the failed resource request.

Operating Systems:

Comments 12 CommentsJump to latest comment

Will Restore's picture

Look at the Detailed Status tab for the job in the Activity Monitor

or try running  Reports > Tape Reports > Tape Logs

in the NetBackup Administration Console.

Will Restore -- where there is a Will there is a way

eagle470's picture

I didn't find anything there, but under the Problems option, by searching the job ID I was able to find '7/6/2013 4:50:01 PM SERVER SERVER.domain.net Error 230850 General NBU status: 800, EMM status: No drives are available'

 
Nicolai's picture

Check the last 3 drives are up and the robots in a operational state.

Usually status "No drives are available" means Netbackup got nowhere to write the backup.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

eagle470's picture

Drives are up, makes me think its a scheduling conflict since I went from 4 drives down to two (I had no choice, read the main portion of the post).

Capture.JPG Capture.JPG
mph999's picture

You could look in the details for the failed job in activity monitor and see what the string is, it seems that it is displayed there.

Also, the nbjm log contains the string, so that is another, but harder option.

I'd start with the activity monitor and see if a cuase could be worked out from there.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
eagle470's picture

Unfortunately there is nothing in the activy monitor other than what I showed in the screen shot attached to my original post. There is no definitive reason stated in the activity monitor, though if you read my reply to the previous post, I did find a bit more information, however, 'No drives are available' is still somewhat vague. I'd like to know if it couldn't connect to the drive or the drive was already in use.

mph999's picture

Yep, sorry, missed that bit ...

Lets see the details from the commands Marianne suggested and well go from there.

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Marianne's picture

Your reason string is:  resource request failed

Please post output of:

vmoprcmd -d

nbrbutil -dump

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

eagle470's picture

I would love to, Is that located under 

C:\Program Files\Veritas\netbackup\bin\admincmd

Marianne's picture

vmoprcmd is under C:\Program Files\Veritas\volmgr\bin

nbrbutil is under C:\Program Files\Veritas\netbackup\bin\admincmd

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Possible's picture

There might be something which is telling that All drives are down.

I think u straight a way go for nbrbutil -resetAll option in admincmd.

That will refresh the EMM ...But lets take a look at nbrbutil -dump as marine suggested.

 

Marianne's picture

In addition to above command output  - please tell us NBU version?

Status 800 was 'cleaned up' in NBU 6.5.6 with more meaningful messages and status codes.
Does this mean you are at still at pre-NBU 7.x version?

How was configuration updated when drive assignment was changed? 
Did you re-config devices as well as Storage Units?

Please show us output of these commands as well:

C:\Program Files\Veritas\netbackup\bin\admincmd\bpstulist -U

C:\Program Files\Veritas\volmgr\bin\tpconfig -l

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links