Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

How do I remove a disconnected disk storage ?

Created: 25 Sep 2012 • Updated: 30 Nov 2012 | 8 comments
This issue has been solved. See solution.

 

I am having the problems removing a disconnected disk from backup exec 2012

I have a disk that I want to remove, there are no jobs associated with it that I can find but I get the error 

 

 

Remove-BEDiskStorageDevice : Unable to delete the disk storage. The device (or
Backup Exec server) cannot be deleted because existing jobs or selection lists
remain.  You must select another target for these jobs or selection lists befor
e you can delete the device or Backup Exec server.
At line:1 char:61
+ Get-BEDiskStorageDevice "Lacie" | Remove-BEDiskStorageDevice <<<<
    + CategoryInfo          : InvalidOperation: (:) [Remove-BEDiskStorageDevic
   e], ManagementOperationFault
    + FullyQualifiedErrorId : ServerBusinessLogic,BackupExec.Management.CLI.Co
   mmands.RemoveBEDiskStorageDeviceCommand

Comments 8 CommentsJump to latest comment

Jaydeep S's picture

1. If there are jobs associated/targated to that storage then you must first retarget the jobs to another target and then try to remove. Go to the Devices tab and then see if you find any jobs for that device, like inventory ora 1 time job that has finished maybe.

2. If still getting the error, then try to restart the BE services and then attempt to remove storage.

simon foster 1701's picture

I have rebooted and restarted the services and still can't delete this disk.

Is there a command that I can run to tell me which job it is that is pointing to this disk as the GUI is not displaying any jobs that are using this disk

pkh's picture

Are you trying to remove the disk using the GUI or are you using BEMCLI?  If it is the latter, try using the GUI to remove the disk.

lmosla's picture

Check for Ghost devices by opening a command prompt and typing  set devmgr_show_nonpresent_devices=1 then enter

Type start devmgmt.msc                   note: for Windows 2008 right click and run as administrator

In Device Manager, in the view menu , click show hidden devices then check your system volumes for any ghosted disk storage devices. 

to remove: click unistall

In the Backup Exec GUI restart the Backup Exec services

 

simon foster 1701's picture

Still not having much luck with this, I have tried using the GUI and BEMCLI both give the same error.

I have tried the procedure above for Ghost devices and have uninstalled the drives but I get the same error when I try andd remove them from backup exec

Is there a way to list the jobs it thinks still exist which are stopping this drive from being removed?

lmosla's picture

Have you installed all of the Live Updates recently?

simon foster 1701's picture

Live Update is up to date, I have the following installed

Service pack 1

Hotfix 189571

Hotfix 180964

Hotfix 194470

simon foster 1701's picture

I have managed to get this fixed at last

I took a backup of my backupexec database just in case and opened up sql management studio.

After a bit of searching around I found the dbo.device table contained the devices that I wanted to delete.

I know this is probably not the best way to fix this issue but it appears to have worked, if not I can always roll back with my database backup.

SOLUTION