Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How does it work: Deployment Scanner

Created: 19 Mar 2013 • Updated: 02 Apr 2013 | 8 comments
STHN's picture
This issue has been solved. See solution.

Hi folks!

Does anyone have a clue, how exactly deployment scanner findy out what has been installed on a system?

I'm asking because according to DS results neither IIS nor EV are installed on a EV server that has been runnung for some time now. EV and IIS are installed.

Another issue is that a newly created archive task fails because - according to EV-logs - there is an unsupported Outlook version installed.

I've double-checkd it. The outlook version is correct.

EV-Version is 10.0.1

Outlook version is 2007 SP3 with AttachmentMax and RecipientMax are configured.

I wonder if there is anything that determines installed software. It that thing is broke it would explain our issues.

Thanks in advance!

Operating Systems:

Comments 8 CommentsJump to latest comment

TonySterling's picture

Where are you running the Deployment Scanner from and are you running the Deployment Scanner logged in as the Vault Service account?   You should be running it on the EV server logged in as VSA.

What version of the Deployment Scanner are you running?  I haven't had any issues with DS so I would tend to think it isn't an issue with the scanner but rather something environmental to your system.

 

Chris Warren's picture

Also, I believe DS is no longer publicly distributed so updates, especially for recent versions of EV (10) may be... quirky :)

TonySterling's picture

Hi Chris,

Could you clarify what you mean?  Deployment Scanner is part of the installation media as recent as EV 10 SP3.

Regards,

 

Chris Warren's picture

Ack...  I was thinking the Deployment Scanner Support tool (DSS) that was pulled.  Sorry for the confusion - need more caffeine!

Thanks for the sanity check Tony.

Rob.Wilcox's picture

Deployment Scanner uses a variety of techniques to get information about the system, and components.. for example checking file properties, and looking for values in the registry.

 

With regards to the Outlook check .. what version of Outlook.exe are actually running?

STHN's picture

Thanks for all the feedback. Someone else is now working on it. So I cannot provide information.

Seems it is an issue with the installation. Currently Outlook and EV binaries are beeing reinstalled.

PMCS GmbH & Co. KG - Consulting und Support für Altiris/SEP/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!

JesusWept3's picture

Typically outlook versions and stuff like that are pulled from registry
SQL stuff tends to be direct queries on SQL Server itself
there are also some WMI calls as well, but its typically registry for the most part, so if you have this issue again, look at running a procmon.

It could also be that UAC is blocking the account, and you might want to run the DS with elevated permissions (i.e Run As Administrator), especially if it starts looking at the \SOFTWARE\ registry key as UAC will start to use Virtualized registry paths which really can mess things up

SOLUTION