Video Screencast Help

How to End a Repeated Library Expansion Option License Error

Created: 18 Nov 2013 • Updated: 22 Nov 2013 | 3 comments
Grayc's picture
This issue has been solved. See solution.

I recently upgraded from BE2010 to BE2012 SP2.  My backup server hardware is a Dell R710 server and a TL4000 with an internal LTO4 tape drive. 

After upgrading to BE2012 SP2, everything worked fine the first week.  The when the second backup cycle started, the backup-to-disk jobs methods ran successfully but the Duplicate stage would not.  

I looked under Window's Device Manager and found the "Medium Changer" was not present, so I shutdown the media server, power cycled the TL4000 tape library then restarted the media server after the tape library was back on line.  When I checked for the "Medium Changer" in Device Manager, I found it.  In BE2012, any duplicate jobs that were queued before the restart, requeued themselves and began to run one after the another. 

What I have discovered is that within a 24-hour timeframe, the media server no longer sees the tape library, and needless to say, the duplicate jobs start failing or are "missed."  Repeating the restart of the server and tape library, brings the tape library back online but just for a few hours and I am repeating the this process again.

Here' is my question, the Dell TL4000 tape library has one LTO4 tape drive so why is BE2012 throwing an alert that I need the Library Expansion Option, when there is no second or more tape drive/tape library connected to my media server?  Since I can successfully see the tape library after doing the restart process I mentioned above, I pretty sure there is not a tape library or tape drive hardware failure.  The 6Gbps HBA card is up-to-date with the its driver and the Device Manager reports it is working properly.

Any suggestions on what else I can do to fix this problem? 

Operating Systems:

Comments 3 CommentsJump to latest comment

Grayc's picture


The tech document reference did help.  I ended up removing the current library partitions I had and creating new ones.  Restarted a duplicate job and now things seem to back to normal. 

Will post an update in the morning.


Grayc's picture

Quick update:

Removing the libary partitions and then re-creating them was the trick that got rid of the Library Expansion Option license violation.  Reviewed all my backup jobs to ensure the duplicate stages were going to the correct library partition.  None of my backup jobs have thrown this error yet!

Imosla - Thanks  for your advice!