Video Screencast Help

How to force Archiving Rule change for all users. EV 10

Created: 26 Oct 2012 • Updated: 15 Nov 2012 | 13 comments
This issue has been solved. See solution.

We are using EV 10.1 whith quota base archiving and we have a override setting " do not archive emails younger than 3 months. I have change the archiving override rule from 3 months to 1 month but still for some users its not archiving the youger than 3 months old email. Which is resulting in mailbox size increased.

Discussion Filed Under:

Comments 13 CommentsJump to latest comment

JesusWept3's picture

any chance of a screenshot of the policy?
Also any chance of upgrading to EV10 SP2 as it generates the mailbox archiving reports at the end and is really good for diagnosing whats actually going on in regards to quota based archiving.

Also do you run EVPM against any of these users?

Maybe something to looking Quota and Date based archiving?

Sudha joshi's picture

Thanks for quick response. Please find the screen shot of mailbox policy.

We have not upgraded to SP2 yet and no plans to upgrade now.

I have Run EVPM aginst some users but not sure if i had run against these users.

What if i had run EVPM against any of the user.

Rob.Wilcox's picture

Your policy is largely quota based .. so once enough has been archived to get them 25% under quota, then archiving will stop.  Even if there are old items in the mailbox.

What sort of EVPM script are you talking about running?

JesusWept3's picture

well basically if you have EVPM say against \inbox and set some custom rules, that will override this filter
so if you have a DoNotArchive or set a custom inactivity period, archiving will obey these rules

So what i would suggest is maybe getting a DTrace and doing a run now
so do the following

1. Open a command prompt
2. CD to your \Program Files (x86)\Enterprise Vault\ directory
3. Type "DTrace" and press Enter
4. Type "Set ArchiveTask v" and press Enter
5. Type "Log C:\QuotaArchiving.txt" and press Enter
6. Minimize the command prompt
7. Open the Vault Admin Console and right click your Archiving Task
8. Go to "Run Now"
9. In Run Move choose "Archiving" and set to "Archive Up To 200 Items" and "Select Mailboxes"
10. Press OK and then choose the mailbox you are targeting
11. You will then get a text saying that its been queued
12. Wait several minutes whilst the archiving process
13. Go back to the Command Prompt and type "Exit" to quit the DTrace

Open up the DTrace and look for the following kind of line
 

EFP - Folder Policy Settings for [Inbox]|  Filter Type = Using users default policy|  Archive Settings Locked = TRUE|  Override Locks = FALSE|  Delete Original = TRUE [LOCKED]|  Create Shortcut = TRUE [LOCKED]|  Archive unread items = TRUE [LOCKED]|  Archiving based on : Age [LOCKED]|  Age Based Period 0 Days|  Using age based size priority|  Minimum Size 200KB|  Do not archive items younger than 0 Weeks

GertjanA's picture

Are the users synced properly?

If they are over quota, the mailbox cannot be synced, and the new settings will not apply. You can try to sync one of the affected mailboxes manually. If it syncs properly, then follow steps as described by JW3

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Sudha joshi's picture

EVPM is set for custom inactivity period as 1 month or 2.

i run the Dtrace for archiving task ang below is the logs:

months.1981 15:29:54.307  [13992] (ArchiveTask) <14756> EV:M EFP - Folder Policy Settings for [Contacts]|  Filter Type = Using users default policy|  Archive Settings Locked = TRUE|  Override Locks = FALSE|  Delete Original = TRUE [LOCKED]|  Create Shortcut = TRUE [LOCKED]|  Archive unread items = TRUE [LOCKED]|  Archiving based on : Quota [LOCKED]|  Quota Percent Free = 25|  Using age based size priority|  Minimum Size 1024KB|  Do not archive items younger than 1 Months

 

 

 

JesusWept3's picture

and is it the same for inbox as opposed to Contacts?

RahulG's picture

Hope your policy is set to Create shortcut and delete the original item .

Sudha joshi's picture

817 15:29:53.090  [13992] (ArchiveTask) <14756> EV:M EFP - Folder Policy Settings for [Top of Information Store]|  Filter Type = Using users default policy|  Archive Settings Locked = TRUE|  Override Locks = FALSE|  Delete Original = TRUE [LOCKED]|  Create Shortcut = TRUE [LOCKED]|  Archive unread items = TRUE [LOCKED]|  Archiving based on : Quota [LOCKED]|  Quota Percent Free = 25|  Using age based size priority|  Minimum Size 1024KB|  Do not archive items younger than 1 Months

 

2091 15:29:54.463  [13992] (ArchiveTask) <14756> EV:M EFP - Folder Policy Settings for [Inbox]|  Filter Type = Using users default policy|  Archive Settings Locked = TRUE|  Override Locks = FALSE|  Delete Original = TRUE [LOCKED]|  Create Shortcut = TRUE [LOCKED]|  Archive unread items = TRUE [LOCKED]|  Archiving based on : Quota [LOCKED]|  Quota Percent Free = 25|  Using age based size priority|  Minimum Size 1024KB|  Do not archive items younger than 1 Months

 

i have run the archiving in report mode for the user and % of free quota is 17.34%.

 

 

% of Quota free

17.34

 

Sudha joshi's picture

Rahul yes it is set to create shortcut and delete original items.

Its working fine for most of users.

RahulG's picture

The EVPM script settings are not stripped or updated by either the EV synchronization (either automatic or manual) or the archiving runs. Did you ran any EVPM script on the mailboxes ?

IF you had then you may try Zapping the mailbox and then enable again using the following document 

http://www.symantec.com/docs/TECH35614

JesusWept3's picture

OK so the policy is definitely being applied, EVPM rules do not exist for the user
In the report does it say how many items are eligible for archiving?

I'm wondering if maybe its something like the bulk is something like calendar items and you don't archive calendar items or don't strip the attachments?

So i suppose what i would do is open the mailbox itself, and get a list of the folder sizes from the property, look at the biggest folders that are causing the mailbox to close to quota...

Then in those folders and sort by age and see if theres anything special about them
Do they have pending reminders and the policy is set to not archive pending reminders?
Is it the calendar that is the biggest and IPM.Appointment does not get archived by default?
Is it maybe that its actually just a large amount of EV shortcuts taking it up to the quota level?
Or could it simply be there just arent many eligible items at all, that its items they've been sending/receiving and getting more items and bigger items within a months date range?

Also its worth looking at the IsEligible statements within the dtrace you captured earlier, it will give an indication what items are eligible to be archived and which ones it will skip for one reason or another

SOLUTION