Video Screencast Help

How to force disk storage policy

Created: 29 Mar 2012 • Updated: 28 Jun 2012 | 6 comments
This issue has been solved. See solution.

hi..

I have a storage issue, the disk pools used in SLP are full, due this, alll deduplication jobs and some backups jobs are failing, so, i think a probably solution for this will be to force SLP start to move images from disk to tapes even they haven't reached the expiration date of disk. in fact.

Comments 6 CommentsJump to latest comment

Yasuhisa Ishikawa's picture

SLP duplicate images to next destination automatically as soon as possible unless you set the SLP or destination inactive. If you don't have tape shortage, images mighe be already duplicated to tapes.

Possible solution is to add volume to disk pool, or to expire copies of images on disk pool to make space.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Marianne's picture

Please note that SLP does not MOVE disk images to tape. It DUPLICATES it.
This means that images are left on disk for quick restores. These duplicated images are then managed by high and low water marks in STU properties.

You need to check if duplications are actually successful and if Image Cleanup runs at regular intervals.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mph999's picture

You cannot force SLP to start duplicating  images, it runs on it's own (if working correctly).

The way to manually run the duplications, is to cancel the image within the SLP, and then manually run bpduplicate.   This might NOT solve the problem though.

1.  As a guess, you have some issue that is stopping the duplications.

You need to answer Mariannes questions - are duplications actually running, and do they wrok.

If they are NOT working, then runnign them manually will not help, they will just get stuck again after the next round of backups.

2.  It MIGHT be the case that there is some problem in the database - this requirs careful consideration and takes time to resolve.

This is the info I usually gather when looking at SLP issues :

mkdir /tmp/symantec

 

nbstlutil list >/tmp/symantec/nbstlutil_list.txt
nbstlutil list -U >/tmp/symantec/nbstlutil_list_U.txt
nbstlutil stlilist >/tmp/symantec/nbstlutil_stlilist.txt
nbstlutil stlilist -U >/tmp/symantec/nbstlutil_stlilist_U.txt
nbstl -l >/tmp/symantec/nbstl_l.txt
nbstl -L >/tmp/symantec/nbstl_L.txt
/usr/openv/db/bin/nbdb_unload /tmp/symantec/nb_unload (zip up the contents)
 
-o 226 log (nbstserv)
 
HERE IS THE COMPLEX BIT:
 
Find out how often the duplications should run (for example, perhpas you should normally see them running every 30 mins.  Double the time, this is time X
 
Get the above info.
Wait a bit longer than time X
Get this info again :
 
nbstlutil list >/tmp/symantec/nbstlutil_list_2.txt
nbstlutil list -U >/tmp/symantec/nbstlutil_list_U_2.txt
nbstlutil stlilist >/tmp/symantec/nbstlutil_stlilist_2.txt
nbstlutil stlilist -U >/tmp/symantec/nbstlutil_stlilist_U_2.txt
/usr/openv/db/bin/nbdb_unload /tmp/symantec/nb_unload_2  (zip up the contents)
 
-o 226 log (nbstserv)
 
I ask for this twice, because I can then compare the two outputs and see what has changed
 
You have to make a choice - do you not run backups until you fix the SLP issue and make the duplications (probably manually).
 
Or
 
Do you cancel the duplications (and not run them manually) to get the backups running quicker ...
 
Either way, you ned to investigate why they are not running, else the problem will happen again.
 
Martin
 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Mark_Solutions's picture

It sounds like you have set fixed retentions on the disk and tape copies of your backups in the SLP

It would be best to do the following:

1. Stop all backups to the SLP for a short while whilst you do the below

2. Make sure all images have been duplicated - if you run \netbackup\bin\admincmd\nbstlutil stlilist -image_incomplete -l

it will show you a list of images that have not been duplicated and hence completed their liefecycle.

3. If there is anything in the list above then try \netbackup\bin\admincmd\nbstlutil inactive -lifecycle lifecyclename followed by \netbackup\bin\admincmd\nbstlutil active -lifecycle lifecyclename

This will deactivate and reactive the lifecycle causing duplications to kick back in within 10 minutes.

4. Once all have completed expire as much as you can from the disk (all of the long term retention images if possible)

5. Edit the SLP to have the disk copy as capacity managed so that the disk will be able to clear down on its own

6. Resume your backups

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mph999's picture

Hmm, good thinking Mark, that is also a possible cause ...

If you post 

 

nbstl -L   output, we will be able to see the config.

Thanks,

 

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Irys's picture

Hi everyone...

I had to ask for support to symantec team (i mean i had to raise a case) to check this issue and all was cause for this process nbevtmgr. For some unknown reason it wasn't working so, the solution was replaced it with a new binary, and everything works normally again.

Thx all for your help.

ιяуѕ 【ツ】

SOLUTION