Video Screencast Help

How to obtain WinPE-512 driver for Intel 82579LM NIC

Created: 02 Jun 2011 | 20 comments
PDM's picture

We recently purchased several Dell Optiplex 790 desktops that have the Intel 82579LM Gigabit NIC. There is not a driver for that NIC included in the WinPE-512 driver list.

We are using Ghost Solution Suite ver 11.5.1.2266 (latest version)

Can anyone tell me how to obtain the drivers for this NIC so that I can add them to WinPE-512.

Thanks in advance.

Comments 20 CommentsJump to latest comment

EdT's picture

Have a look in this forum using the search engine for any past postings with 82579 in them - there are frequent postings giving links to suitable drivers for different chipsets.

Aside from that, you can grab drivers from the DELL site, but make sure you use Vista 32 bit drivers as this is what is required by the version of WinPE used in GSS 2.5.1

You need the drivers in the form of INF SYS and CAT files (at a minimum) so if they come in the form of an EXE, they will need to be unpacked or extracted before use.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

PDM's picture

EdT,

Thanks for the reply.

I did go to the Dell drivers website and download the driver installation file. I "installed" it on my PC and it unpacked the entire driver package on my PC, but because my PC doesn't have that NIC it didn't install.

Inside the associated folders are drivers for XP, Vista and Windows 7 for both 32 bit and 64 bit. We're planning to use Windows 7 32 bit on these PCs but your suggestion was to use the Vista driver because that's what Windows PE uses. So it's not the OS that we're going to install on the PCs, rather the driver needs to be compatible with the version of Windows PE (in our case WinPE-512) that is being used by Symantec Ghost?

I think I understand now, I just want to confirm.

Thanks again for your valuable assistance. I'll test and report back if all works well.

brocinco's picture

i have already downloaded and unpackaged the intel nic driver for optiplex790 and still no luck. 

i have gone through every step in ghost boot wizard correctly (i know this because my older laptops/desktops work perfect) but i still get errors. 

errors:

(server side)- receive error 10054

(computer side)- boots windowsPE, then when ghost main screen shows, my shared drive is not mapped. if i go into the command prompt of ghost and type "ipconfig" i dont get any settings. also if i type the command "net use...." it comes back with an error. this leads me to beleive that it is my nic but i dont know what else to do. i have already tried both driver from the dell website (broadcom and intel) just in case, but still same thing. i may add that i removed vista and installed windows 7 64 bit on the optiplex790 machine. 

any help will be greatly appreciated. 

thanks in advance

EdT's picture

If you have a working O/S on your 790 then go into device manager and have a look at the device ID for the NIC. Then open the INF file from your Vista 32 bit driver fileset and check that the Device ID is in the INF. If it is not, then the drivers are not compatible with your NIC.

Clearly as you cannot get an IP address, the NIC drivers are not loading or are not compatible with your hardware.  If you want to try different drivers without having to rebuild the WinPE boot each time, you should be able to load them from the command line. Just type DRVLOAD <full path and filename to INF file> and make sure that the INF SYS and CAT files are in the same folder (eg on a USB key). If the driver loads OK then WinPE will tell you.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

brocinco's picture

@EdT:

thank you for your advice. did everything you recommended and it worked great. DRVLOAD was a great help. saved a lot of time. 

thaks

brocinco's picture

@EdT:

after trying everything you mentioned, i can manually install the driver and map the drive and everything works great. 

however: when i go into the server end, and add the driver (the same driver that i install manually via command prompt) and reconfigure winpe, my optiplex790 still doesnt connect to my server. the optiplex790 boots winpe and ghost but it still wont get an IP address. i know the reason it wont map the drive is because it wont get an IP but i dont see why its not getting an IP if im using the same driver both in command prompt and in Ghost Boot Wizard. i have noticed that when i choose to "add new driver" in winpe, it only lets me select the folder that the driver resides in, and not the actual driver. so my question is this: what files should be in that folder? as of right now i have these files....

e1c6032 (security catalog)

e1c6032.din

E1c6032 (setup information)

e1c6032.sys 

e1cmsg.dll 

NicCo26.dll

NicInstC.dll

PROUnstl (application)

readme.txt

release.txt

.....should i have all these files? or are they causing issues?

thanks in advance

RustySmith's picture

 

I just worked through what may be the same problem with help from HP for the Elitebook 8560p laptop, which has the Intel 82579LM driver (Dev ID = 1502).

 

I don't know where I went wrong initially, but using the correct driver download from HP worked perfectly by the book.

 

We have Altiris 6.9 SP2 in production, WinPE2.1 (which requires Vista drivers)

The download of the Vista Enterprise 32-bit driver from HP for this adapter on this laptop ishere.

 

I extracted this file (SP52209.exe /e), and then pointed the Boot Disk Creator "Have Disk" dialog to the directory \flat\VISTAx32. The file that is there waiting to populate the driver window is E1C6032.inf. This driver covers Dev ID 1502 and 1503.

 

With the PXE Configuration Utility set up with this updated WinPE image, I was able to PXE boot and image the 8560p with no problem.

 

One of the problems I encountered along the way was due to creating a new WinPE image rather than editing the existing (I'm new to all this, and didn't want to break what was already working...). This resulted in our imaging jobs not loading with the correct WinPE image - I had to go into those image job tasks and set the Automation pre-boot environment to the name of the new WinPE image. 

 

Hope that helps!

EdT's picture

Your experiences getting this working will no doubt help others with the same chipset.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

EdT's picture

Any surplus files should not cause any issues. At the very least you need an INF SYS and CAT file but its not unusual to have some DLL files as well. The INF file usually has a list of the files it uses somewhere in the code if you care to open the INF in a text editor.

There is also one other thing worth checking. Since the plug and play process searches through INF files looking for a match for the device ID, it is not impossible that there is already an INF in there with a compatible code that is getting loaded instead, and thus not working correctly. Consequently, checking through your driver list and removing anything that your machine inventory does not need may also help.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Aoyagi-san's picture

I've been experiencing the same trouble as the OP, but with Lenovo m91p small form factor towers.  The 82579LM driver I'm using says it loads successfully using DRVLOAD from within the PE environment, but I'm unable to get network.  The same happens when I PXE boot with the driver "integrated" into the WinPE wim file.  I've also looked through all the drivers that are tick marked and none of them have a matching PnP id to the one for the 82579LM so I'm at a loss as to where to go from here.

EdT's picture

So are you saying that none of the driver INF files you have sourced have a PNP ID which matches your Lenovo m91p 's NIC card?  Are you sourcing the Vista 32 bit driver from the Lenovo website? What is the PNP ID for the NIC in your Lenovo ?  (You can try using the PNP ID as the search term in Google as this often throws up driver sources).

Also, if you have the INF file from the Lenovo site, open it and check which files are listed as being in the driver set, and make sure all are available to your WinPE setup. Occasionally, there are files in addition to the INF SYS and CAT files - maybe an extra DLL or two.

Finally, when you say that the network is not working, could this be caused by the NIC defaulting to the wrong speed and duplex setting? Sometimes a default is also set in the INF file (ideally an "Auto" option should be default), but this can be changed by editing the INF to suit your specific environment.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

vsharma's picture

I have got it working, I downloaded the driver executable from :

http://downloadcenter.intel.com/Detail_Desc.aspx?a...

 

Then extracted via WinRAR (use any extraction tool) and then added via the extracted folder (ProWin32\...\Pro1000\win32\NDIS61) find the e1c6032 driver (which didnt work) but also added the e1e6032 driver and it worked with that one.
 
You can install either via the Web console or via the BootWiz application on the Notification Server.
 
After installing check that e1e6032 driver is available in C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\bootwiz\platforms\winpe2\x86\drivers\custom
 
Perform a Delta Upgrade on the NS and then wait for it to move through the task servers (or manually perform) and all works well am able to image fine now.
vsharma's picture

The machine I was having trouble with was a HP 8200 Elite SFF and Altiris / Deployment Solution 7.1

Credit doesnt go to me but to Ken Kump and co who patiently helped me and pushed to get this fixed... genius!

Alix Holbrook's picture

I'm trying to install drivers for the Intel 82579V and 82574L chipsets. I've tried selecting the entire NDSI61 folder which contains drivers for both chips, and seperating out just the .inf, .cat and .sys files, along with the .ddls referenced in the .inf file. neither seems to work.

There are some drivers for the intel chips that you can not unselect, which is how I had got the RealTek driver I needed to load correctly.

If they work by loading them manually, what is the next step?

 

Thanks,

Alix

EdT's picture

Add them to WinPE and then make sure the drivers are selected before creating a new WinPE boot file.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Alix Holbrook's picture

I installed the driver, and selected it and rebuilt the PE image.

 

Even if I try drvload, it says it's successful, but ipconfig doesn't show the NIC.

kamaldva's picture

Once you extract this file ,Try to add the folder to WIN PE-512. It should fix the issue

AttachmentSize
Intel 82579-LM.7z 226.29 KB
jt-tech's picture

Thank you for posting your copy of the Intel 82579-LM drivers Kamaldva.  I have been struggling for the past several hours trying to get the 82579LM Vista drivers from Lenovo's website to work in WIN PE-512.  I tried every driver I could find, but yours was the only one that worked in WinPE.  Thank you for the help.

Michael Panagos's picture

I tried the exact same drivers, but newer versions, and they did not work. Though the ones posted by kamaldva are from 2010 and have some Dell specifics in them, they worked on our new Lenovo X220 tablets.

semberton's picture

I was able to get our Lenovo T420 booted into WinPE by using these drivers for the 82579LM NIC. I searched so many places, I can't remember now where they came from, but I'm thinking it was on HP's website.

I tried the above drivers though at some point without success.

AttachmentSize
Intel 82579LM WinPE.zip 285.77 KB