Video Screencast Help

How to online Service group

Created: 22 Feb 2013 | 2 comments

Hi,

How can online a service group as I already add a resource but when I am executing, hagrp -online group -sys node then its showing an error message as,

--> There are no resources in the group to online.

 

when I see "hagrp -state", the group states are showing as OFFLINE

when I see "hares -state", the resources states are showing as ONLINE

Kindly assist to resolve the issue.

Thanks

Discussion Filed Under:

Comments 2 CommentsJump to latest comment

mikebounds's picture

It maybe because the group only contains persistent resource(s) (like just a NIC - can you post your main.cf (in /etc/VRTSvcs/conf/config)

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

Gaurav Sangamnerkar's picture

Do you have any resources configured in the group ?  Is this a new install ?  If you have just added a group to the configuration & trying to online it , have you saved the configuration ?

If this is an old setup ,Mike's assumption is precise ..that's the most probable possibility to have only one persistent resource .. If thats the config, you may need to add a phantom resource in order to detect the service group state

If thats not the case too, post the engine_A.log from the time you are triggering the online command ..

also paste the main.cf file & hastatus -sum output ..

 

G

 

 

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.