Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

How to Recover Deleted Active Directory User Account

Created: 30 Jun 2013 • Updated: 30 Jun 2013 | 2 comments
Tony Lombardi's picture

A client of mine deleted a user account and disconnected the Exchange mailbox.  They have Backup Exec 2012 with all the latest updates.  I am unclear on how to restore the user account.  I was able to run the restore wizard and and select the one user account to restore, but I am concerned about running the restore job.  My question is this.

Does the server need to be in Active Directory restore mode to restore the one user account or can the user account be restored while the server is in regular production mode?  Restoring it while the server is in regular production would be the least disruptive to the network users.

A quick answer would be most welcome.  I'm pretty sure I can reconnect the mailbox, which is still present in the disconnected mailboxes folder.

Tony

Operating Systems:

Comments 2 CommentsJump to latest comment

Colin Weaver's picture

If you can actually select the user account then that means GRT was enabled against the backup job and you should be able to go ahead and do the restore without coming out of standard/in use mode for Active Directory

Note: You only need directory services restore mode and/or considering authoritative vs non-authoritative restores when restoring the whole of Active Directory (in other words the System State) GRT does not need it.

BTW: I hope you had an Exchange GRT backup as well in order to recover the mailbox

Tony Lombardi's picture

Thanks for your quick reply.  It is much appreciated. 

Yes GRT is enabled and I can select the deleted object from the last backup.  I'll give a go while the server is in production and see what happens.

By the way, the user mailbox went into the disconnected mailbox folder within Exchange.  It should either reconnect or I will manually reconnect it.  Nevertheless, yes, GRT is enabled for Exchange as well.

Tony