Video Screencast Help

How to remove AUTORUN.INF file???

Created: 06 May 2009 • Updated: 21 May 2010 | 15 comments
This issue has been solved. See solution.

My pc contains this file in every folder
how can i remove it???

Comments 15 CommentsJump to latest comment

pete_4u2002's picture

update the system with the latest RR , scan the system in safe mode.
disable the autorun execution uing group policy or


Om_123's picture

goto services.msc
stop the autorun service
start in safe mode .
run the virus scan .

Paul Mapacpac's picture

After scanning the files, you can use the search tool of windows to search for autorun.inf files then delete them all.

Peter_007's picture

open command promt

type following command

Attrib -s -h -r autorun.inf

del autorun.inf

then restart your pc

Owais's picture

go through this can help u........


• While the computer is still off;

• Plugin the USB Drive

• Insert the Windows XP CD-ROM into the CD-ROM drive. It must be the bootable Windows XP Installer

• Start the computer from the CD-ROM drive. It will start Windows Setup screen

• When the “Welcome to Setup” prompt appears.Press “R” to start the Recovery Console

• If asked “Which Window installation would you like to logon to” select the number. Type “1? then Enter, if only one installation of Windows is present

• Enter the administrator password, press Enter

• It will bring you to command prompt, C:\Windows>

• Proceed with the following command:

- Type d: (This is the drive letter of USB. It can be e: or f: defending on how many hard disk or cd drive is installed)

- Type attrib -h -r -s autorun.inf

- Type “edit autorun.inf” it will open DOS Editor and display contents as follows


Take note on the file that it called to open (in above example it is file.exe)

• Exit DOS Editor and return to command prompt, D:\>

• Delete the file that was called to open on DOS Editor
- Type del /f /a file.exe

• Delete autorun.inf file
- Type del /f /a autorun.inf

• Exit Recovery Console by typing exit

windessy's picture

first of all you need to find and clean virus, that make this files.

Невозможно жить в обществе без чёткой цветовой дифференциации штанов (С)

nick_123's picture

try to disable autorun feature from services.msc

ShadowsPapa's picture

If on a network, you can disable autoplay using a GPO.
You can block acccess to CREATE, READ, DELETE, COPY etc any autorun.inf file using SEP.
I setup an application rule - nothing can create or access or read a file called autorun anywhere on any computer in our agency now thanks to SEP.
So even if there IS still a worm or virus attempting to create them, SEP blocks said creation or access attempts and better yet, NAMES the process that's attempting to read/create/run said file.
Go into SEPs application and device control and setup an application rule to block such files - IF you are running SEP and not SAV.

That will tell you where they are and what is attempting to access them - from that you can find and kill that process.

Ajit Jha's picture

Hi Sujay

If u got the solution please mark as solution.



Ajit Jha

Technical Consultant


nick_123's picture

i think your pc may be infected by virus..y dont u update ur AV and try to remove and find is that file present there only??

Peter_007's picture

 hi sujay
please reply if your problem is resolved


nick_123's picture

b4 that, once u inserted ur PD in slot.....then go to that drive from command prompt (type "cmd" in RUN)....and delete .inf and .exe files from commond prompt only......then u can open ur will not harm ur system....

Bijay.Swain's picture

No need to go anywhere just open command prompt

c:\>attrib -a -r -s -h
c:>del autorun.inf.

or go to
 and download the tool to remove autorun.inf

it will do the work for you.