Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How to remove old servers

Created: 17 May 2013 | 7 comments

Hi, we have Netbackup 7.0.1 running on Windows 2008 R2. All media servers have same version. i have couple of questions:

1. When i am configuring new tape drives today using Configure Tape storage wizard i noticed it is listing old media servers which have already been decomissioned (using nbdecomission command). Why they are still coming in the list of media servers. How to remove them from that list?

2. Also i was runningnbcc and it found some images which belongs to media servers which are already decomissioned. How to get list of these images which shows image owner so i can identify which images need to be migrated. And also how i can move those images to new media server?

3. Also on Credntials tab we have all NDMP hosts which also lists all media servers. When we are adding new NDMP host it is adding al lavailable media servers to list. Is there a way to limit this to only specific media servers? also i have many NDMP hosts which shows old media servers. How to remove them?

Thanks in advance for all your answers and help

Comments 7 CommentsJump to latest comment

huanglao2002's picture

Hi Amaan

You can reference http://www.symantec.com/business/support/index?page=content&id=TECH62119

"What is the process for decommissioning a NetBackup 6.5 or 7.x media server".

Marianne's picture

1. Hopefully removing them from EMM will remove them from the list: 
nbemmcmd -deletehost -machinename <old-server> -machinetype media

2. Seems nbcc gave you this list?
You can probably try bpimagelist command with '-server <old-server>'
I do not have access to a server right now to test, but I would add '-d <start-date>' to go back far enough to catch all possible images.

3. That is how it works in the GUI.
The alternative is to add it from cmd on each media server.
tpconfig -add -nh <ndmphost> -user_id <user-name> -password <password>

PS: It almost seems if nbdecommission was not 100% successful?
Here is another user with a similar experience: 
https://www-secure.symantec.com/connect/forums/unable-delete-media-server-emm-db#comment-8166561

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Amaan's picture

Thanks Marianne as usual. When i add NDMP using above command it is still showing this credentials for all servers listed in the emm. is it normal.

huanglao2002's picture

Can you follow Marianne advice,you can delete old media server first.and then add the ndmp host.

Marianne's picture

Apologies - I have missed your last post.

Are you using the command on media server or on the master?

If you are adding it on a media server and the GUI shows it for all media servers, there is one of two possibilities - 

1. There is a bug in your NBU version
2. This is what NBU does.

I honestly don't know and I don't have anywhere to check/test this..... 
Sorry....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sazz.'s picture

Please check the below settings:

Credentials-NDMP hosts - open the properties of NDMP host - there would be three options. Which one you are using ??

1) Use global NDMP credentials for the host

2) use following credentials for all media server

3)use different credentials for this ndmp on each media server

Select the third option and click on advanced configuration and you will be able to remove the media server and add them as you want.

I am using the 3rd option and can add or remove the media server as I want. Just to note I am on 7.5.0.4 but it was the same configuration on 7.0

Abhishek Tomar's picture

I believe you are able to resolve issue with drive and ndmp credential from above answers.

For NBCC issue check with Symantec support as they have utility to analyze it and it will generate a report where there would be any inconsistency.

If any image still belongs to an old media server it means that decommissioning was not proper.

Once list of inconsistent imgaes will be generated by Support they will give you the respective command to execute .

If you get the image detail and want to move image of tapes  from one media server to another , you can use following command

bpmedia -movedb -ev media_ID -oldserver old_server
-newserver new_server.

Hope it helps.