Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How to set the Port Range for PBX on an AIX client

Created: 15 Nov 2012 • Updated: 16 Nov 2012 | 3 comments
This issue has been solved. See solution.

Hi!

I have following issue. An AIX client that we backup with NetBackup 7.1.0.2 has a local application running that needs a specific on the loopback device. Now it appears that PBX randonmly picks a port to use and as such it happened that it picked the exact port that the application was using. I did some digging and found following technote to this topic:

http://www.symantec.com/business/support/index?pag...

The information in here is a bit confuse however. It seems to mix AIX with Windows terminology. I tried to extraploate the information I would need and thought to do add the following into /etc/vx/VxICS/VxPBX.cfg

"CLIENT_PORT_RANGE"="50001-65536"

Yet when the I restarted PBX I found this in the log /opt/VRTSpbx/log
2,50936,103,103,1,1352984566282,491852,1,0:,108:ACE_Service_Config directive: "static PBX_Manager ' -debuglevel 10 -authuser root -outside 1556 -insecure '",0:,0,(0|)
2,50936,103,103,2,1352984567025,491852,1,0:,44:PBX_Manager::open, searching all interfaces.,0:,0,(0|)
2,50936,103,103,3,1352984567026,491852,1,0:,0:,0:,0,(24|)
2,50936,103,103,4,1352984567026,491852,1,0:,0:,0:,0,(25|)
2,50936,103,103,5,1352984567026,491852,1,0:,63:Exchange listening on outside port 1556 for client connections.,0:,0,(0|)
2,50936,103,103,6,1352984567026,491852,1,0:,66:Exchange listening on inside port 45103 for service registrations.,0:,0,(0|)
2,50936,103,103,7,1352984567026,491852,1,0:,69:Exchange listening on old inside port 1557 for service registrations.,0:,0,(0|)
 

Any ideas on where I went wrong? Help would be greatly appreciated

Thanks

Chris

Comments 3 CommentsJump to latest comment

CRZ's picture

The TechNote directions actually point to you putting something which looks like a Windows registry key into a UNIX file (/etc/vx/isis/Registry).  It's specifically dealing with VxSvc, though, and I don't think there's a VxPBX equivalent.

I'm not entirely sure there's anything configurable within PBX for this - the only document reference I could find relates to that particular port being "kernel assigned" - whatever THAT means.  You might want to open a case with us and see if you can get a better answer.


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
revaroo's picture

Chris,

I think you're right, we can change the port PBX listens on, but I don't think we can control it much further than that!

Christoph Maier's picture

Well, thanks for the help guys. Too bad that there appears to be no real solution. As it looks like the port is being random we decided to just leave it at that. Should the problem occur more often I'll open a case.