Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

How to upgrade the SEP client into the latest client version 12.1 RU2 without rebooting and without prompting the user ?

Created: 03 Feb 2013 • Updated: 25 Feb 2013 | 6 comments
This issue has been solved. See solution.

Hi,

I'm trying to suppress the SEP client upgrade prompt and also avoid reandom reboot for all of the workstation and server in the domain to avoid confusion, so that the upgrade can be applied successfully after they shutdown their PC or the next Windows Update reboot.

 

How can I achieve this ?

 

Comments 6 CommentsJump to latest comment

Ambesh_444's picture

Hello,

 

Please Check mithun's comments in one of thread.

 https://www-secure.symantec.com/connect/forums/symantec-endpoint-protection-1212-client-push-problem

Mithun Sanghavi

Hello,

In the Enterprise version, you can use Upgrade Clients with Package to upgrade existing clients:

However, the following cautions apply:

  • If you upgrade from 11.x and use Application and Device Control, you must disable the Application Control rule "Protect client files and registry keys." After the clients receive the new policy, you may upgrade using AutoUpgrade.

  • Due to possible bandwidth concerns, it is best to schedule AutoUpgrade for after hours. You can also stage and select a package on a web server when you run Upgrade Clients with Package, or you can use an alternate method to deploy the upgrade package.

AutoUpgrade is enabled by default for SEP SBE, but you can disable it. Go to the Computers page in the management console, right-click your Group, select Properties, and then click Disable Automatic Client Package Updates.

Reference:

Best practices for upgrading to Symantec Endpoint Protection 12.1.2

http://www.symantec.com/docs/TECH163700

Steps to prepare computers to install Symantec Endpoint Protection 12.1 client

http://www.symantec.com/docs/TECH163112

 

http://www.symantec.com/business/support/index?pag...

https://www-secure.symantec.com/connect/articles/s...

 

 

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

.Brian's picture

Two settings you need to configure.

When you created the package under Admin page >> Install Packages >> Client Install Settings, select the "Schedule Reboot" tab and set it to what you want here.

Than second step:

Go to Clients page >> select a group >> Policies tab >> General Settings >> Restart Settings tab

Set it to what you need it to be.

Configuring both of these will get you what you need as you can supress the reboot by configuring these 2 settings.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

SOLUTION
John Santana's picture

Cool, many thanks for the advice and suggestion people.

I'm trying to prevent the user getting prompted for a reboot. My initial idea is to silently install / upgrade the SEP client from 12.1 RU1 into 12.1. RU2 so that it doesn't cause user confusion.

if it is 11.0.4 into 12.1.2 yes I understand that it is a major upgrade (especially from Teefer2 into Teefer3 which sometimes broke the network connection)

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.