Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

How to use Ghost 11.5.1 - Windows Server 2008 without sysprep?

Created: 18 Mar 2013 | 5 comments

 

We deploy windows based servers appliances (Windows 2003 / 2008 Standard Server), all of which run in a "Kiosk" sort of fashion.  We buy a multi activation key from Microsoft and have a special server build that needs to look and feel the same at each site (ie security – ip addressing – server name – licenses etc) – all servers are created equal on same exact hardware.

A while back we used Ghost (DOS) 8.2 to create our windows 2003 server image file.  When we cloned the images everything came over from the image file.  Today our manufacturing company told us to use Ghost (DOS) 11.5.1 with sysprep.exe.  I really didn’t think sysprep was necessary since each build server should be the same. In addition it’s a pain to clone my image of the server; hence I saw that the interfaces (names / ip addressing / metrix etc) were blank.  I also noticed that the Microsoft license has been reset to invalid.  Is there any way around sysprep?  Why is this info not appearing on my cloned image?  Am I missing something?   Please give me some pointers on how I can this process easier. 

Thanks,

Ghost - line command.

c:\ghost\ghost.exe -clone,mode=load,src=c:\ghost\images\6550-R4\0362012.gho,dst=2 -sure -rb

Operating Systems:

Comments 5 CommentsJump to latest comment

EdT's picture

What happens when you try imaging without Sysprep in the "old" way?  If you are using a volume MAK key then it should be able to handle the re-activation that will inevitably be necessary if you are using any newer server operating systems.  Sysprep, as you will have noticed, removes all activation and license information but you should still be able to use your volume MAK key in the sysprep.ini file to define the licensing information during mini-setup.

One other issue you may encounter, however, is that modern hardware is increasingly incompatible with DOS, and you may need to move to WinPE to be able to access your hard disk subsystems for imaging.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

sstatires's picture

When i try to clone windows 2008 server  the old way using Ghost 8.2 (dos), I get a winload.exe error with status: 0xc000000e.  So you are telling me that the only way to clone these 2008 servers is to clone the image and then run sysprep??  I really don't see any benefit for the consumer (us), especially after running the sysprep /w MAK key.  Now my Tech will need to log into each of the servers and manually change the NICs ip addressing - NIC descriptions (multi-homed) and the NIC metrix order.  This is not fun.. it's going to take 10x the amount of time to image our servers.  Maybe i need to look at another imaging product.  If you can shed some more light on a better process - please do.  

EdT's picture

First of all, sysprep has to be run BEFORE you create an image and not after. However, winload errors can be caused by many other things, and I suspect the fact that you are still using DOS is one likely contributor to your situation.

Check out Paragon Hard Disk Manager 12 (cost me 12 GBP retail) as this can take images, but uses WinPE as the boot environment, in the same way that Ghost 11.5.1.2266 provides a WinPE environment for use with modern hardware.

Are you imaging 2008 or 2008 R2 ?  If R2, are you capturing both partitions?  As R2 is based on the same codeset as Win 7, it is likely to use the same disk structure, ie a small system partition of around 100Mb and the main boot partition containing the majority of the operating system files. If both are not imaged and restored to a target, it is just not going to boot.  Making a disk image rather than a partition image is a simple way to get around this.

Bear in mind also that DOS uses CHS addressing for hard disks, whereas the standard nowadays is LBA. CHS has some serious limits, and in addition, DOS has no support for SATA drives, so will not be able to "see" hard disks on most modern system unless the bios offers a "compatibility" mode allowing it to emulate the older Parallel ATA standard.  If imaging in compatibility mode, both source and target machines must be set to this otherwise the CHS-LBA translation will cause problems.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

sstatires's picture

 

Ed.. Thanks for your input – it really helped.  Okay now I got Ghost32 working on winpe 3.0 and it so much faster.  So now that I ran sysprep before the imaging process and now that I did a restore, it’s a pain going through all my steps on configuring the server (see my nine steps to prepare each server).  Is there a better way to automate or script this?  Please advise me if there is..

1)       Need to configure the two interfaces -  NIC 1 has a static ip

2)       Need to configure NIC 1 TCP/IPv4– properties/advanced interface metric = 1

3)       Need to disable NIC 1 TCP/IPv6 to disable

4)       Need to rename NIC 1 to “LAN”

5)       Need to configure NIC 2 TCP/IP – properties/advanced interface metric = 2

6)       Need to disable NIC 2 TCP/IPv6 to disable

7)       Need to rename NIC 2 to “WAN”

8)       Need to change the NIC binding order NIC 1 or “LAN” needs to be first and NIC 2 or “WAN” needs to be second  (Network Connections - top menu – Advance / Advance settings).

9)       Lastly we need to stuff the new MAK into the OS by executing “slmgr /ipk {Win2008 Std server Product Key #} – execute “slmgr /ato” – lastly execute “slmgr /dli”.

Yikes!!  I just need to do this every time I ship a server from our manufacturing department or ship a server from our repair center.  

EdT's picture

I suspect a large proportion of your settings cause registry changes, so if you can capture these changes then it becomes a simple operation to just insert the necessary registry keys.

Alternatively, a free tool called AutoIT by Hiddensoft can enable you to automate windows mouse and keystrokes so that you can just run a script and watch the windows pop up and be updated automagically.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.