Video Screencast Help

Howto : intalling RALUS v12 on Debian

Created: 25 Apr 2008 • Updated: 21 May 2010 | 4 comments

I really needed to upgrade to v12, and since the legacy agent is no longer supported, I had to figure out some way to make this this new unsupported agents work on Debian.
There might be better solutions, but this works fine :)
In case there are others trying the same thing I'm sharing this with you.

--------------------------------------
On Debian 4 :
--------------------------------------
apt-get install libstdc++2.10-glibc2.2
apt-get install rpm
ln -s /usr/bin/rpm /bin/rpm

unpack the ralus-archive and run installralus.

--------------------------------------
On Debian 3 :
--------------------------------------
apt-get install alien

(unpack BEWS_12.1364_LINUX-UNIX-MAC_AGENTS.tar.gz in a directory of choise)

mkdir tmp && cd tmp
tar -zxvf ../pkgs/Linux/VRTSvxmsa.tar.gz
tar -zxvf ../pkgs/Linux/VRTSralus.tar.gz
alien --to-deb VRTSvxmsa-4.4-023.i686.rpm
alien --to-deb VRTSralus-12.0.1364-0.i386.rpm
dpkg -i vrtsvxmsa_4.4-24_i386.deb
dpkg -i vrtsralus_12.0.1364-1_i386.deb
cp /opt/VRTSralus/bin/VRTSralus.init /etc/init.d/


edit /etc/VRTSralus/ralus.cfg, and add the line:

Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Agent Directory List_1=your mediaserver ip

(yes,specify your ip;))

create the group beoper and add your backup user(s) to this group

Don't forget to link the new agent under rc?.d, and remove the old one.


You may miss some tools, but at least you got the agent.

Message Edited by Raven on 04-25-2008 04:42 AM

Comments 4 CommentsJump to latest comment

Raven's picture

EDIT:

Som of my boxes missed all theese lines from the config (comparing to a normal install), add if needed:

Software\Symantec\Backup Exec For Windows\Backup Exec\Agent Browser\TcpIp\AdvertisementPort=6101
Software\Symantec\Backup Exec For Windows\Backup Exec\Debug\AgentConfig=0
Software\Symantec\Backup Exec For Windows\Backup Exec\Debug\VXBSAlevel=5
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Advertise All=1
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Advertise Now=0
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Advertisement Purge=0
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Advertising Disabled=0
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Advertising Interval Minutes=60
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Auto Discovery Enabled=1
Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\Agents\Agent Directory List_1={your mediaserver ip}

Ben L.'s picture

Please review the list of supported Linux/Unix operating systems on the Software Compatability List.  At this time Debian is not supported by the RALUS agent.

http://seer.entsupport.symantec.com/docs/295304.htm


If this response answers your concern, please mark it as a "solution"

hooky's picture

I followed the above instructions on howto install radius on Debian 4. The installer ran perfectly (i did have to download it, as the cd version didn't run at all). But, as i run the init script I get this:
projecten:~/symantec/temp# /etc/init.d/VRTSralus.init start

Starting Symantec Backup Exec Remote Agent ..............................
Starting Symantec Backup Exec Remote Agent:                              [FAILED]
projecten:~/symantec/temp#

I doesn't give me any info on what's going wrong. Can anyone help me getting this working? Maybe it's a port thing, or just a small configuration error, but I haven't bene able to find a log.

Thanxs in advance


hooky's picture

Well, good news, i found the log and resolved my problems.
Error log can be found in  beremote.service.log:

/opt/VRTSralus/bin/beremote: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

Just do: apt-get install libstdc++5
... and problem solved.