Video Screencast Help

HP 7320 all in one w/Realtek GBE PCIe Family Controller Imaging Speeds

Created: 07 Aug 2012 | 10 comments

I am having trouble with all our machines that currently have the Realtek GBE PCIe family of Ethernet controllers, specifically the HP 7320 All in one and the HP Folio.  I did eventually get the drivers added to Windows PE because apparently the Universal Drivers don't work.

For some comparison, our other HP desktops use broadcom cards with the Universal network drivers and image at 2800 MB/min.  The machines with Realtek cards, using Realtek drivers, image at about 1000 MB/min.  Not a HUGE issue if I am only doing one, but doing a whole lab takes 4+ hours rather than 30 mins or less.

Has anyone else experienced this with Realtek drivers or have a fix?  I am using drivers straight from Realtek (HP only has 64 bit Windows 7 drivers on their site for these 2 models) and adding them manually as NDIS, although I think I have also tried adding the other type.  Let me know if any other info is needed.  Really looking for someone else who has found a fix for this though.

Even our 5+ year old HP desktops image at 1800 MB/min...very frustrating.

Comments 10 CommentsJump to latest comment

EdT's picture

Might be worth looking at the default settings in the INF files of the Realtek drivers in case they are not optimal for your environment.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ctafflinger's picture

According to the spec sheet for the 7320, it uses the RTL8171EH GBE controller.  The only designation I can find anywhere is in the 816# range, nothing in the INF for 8171.  And then here there is nothing about 8171 in the INF file.

Strange?  Or am I missing something?  I can't find reference to 8171 anywhere.  Even the drivers from HP don't list 8171 in the INF.

Appreciate your input.

ctafflinger's picture

Doing some browsing around in the INI file.  The hardware IDs listed on the computer are:





None of these are listed in the INI.  Would that at least be the reason why Ghost isnt finding the driver automatically?  However, PCI\VEN_10ec&dev_8168&SUBSYS_1899103C is found in the 64 bit INI file.  Could this be a clue to the issue?

EdT's picture

Struggling to find the correct drivers for a new build is a perennial issue so I wrote a little utility ( that reports on all the Device IDs in any computer running windows, plus associated INF files, etc.

I have found that searching with Google on a specific device ID would often lead me to a valid driver download.

Two things to bear in mind:

1. WinPE, as used in Ghost, is based on the Vista 32 bit kernel so you need Vista 32 bit drivers for addition via Ghost Boot Wizard

2. The drivers needed by your operating system will be whatever the operating system needs and this has nothing to do with the drivers used in WinPE.

Those points aside, if you have a working set of drivers then at some level the driver INF file is being selected as a valid source of driver information for your NIC. Thereafter, any performance issues may be due to a multitude of other factors.

Taking Ghost out of the equation, how does one of these HP machines compare on transfer rates under windows when benchmarked against one of your other machines?

It is easy to blame the NIC driver for all performance ills, while losing sight of the fact that transfer rates also involve the computer bus, memory, and hard disk data channel. Perhaps the SATA drivers for the hard disk are not optimal for the chipset? Perhaps there are additional utilities for the computer chipset that are required to optimise speed?

The transfer rates you quote suggest that you must be running Gigabit LAN. There are different possible configurations which may be mediated by the INF file if is has default settings, so this is why I mentioned this in a previous post.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ctafflinger's picture

Hmm...yes ok Ill look into all that, but here's something curious.

No matter what I add to the WinPE image, it doesn't find the right driver and doesn't work.  If I modify the template for the Realtek GBE PCI Family Drivers, delete the Universal drivers and add in Packet drivers for Vista 32 bit then it works, but slow (1000 MB/min).  

If I specify 64 bit Windows 7 drivers via Packet, then the Folio jumps up to 1600 MB/min.

If I specify 64 bit Windows 7 drivers via NDIS, then the Folio images at 2100 MB/min.

Now trying the 7320 with Windows 7 64 bit drivers via NDIS and its hovering around 1700 MB/min.

All this goes against the conventional wisdom of using Vista 32 bit drivers, no?

Ill answer your other questions as well :)

Thanks again.

EdT's picture

If the Win 7 drivers are also compatible with Vista then they will work correctly. Bottom line is that if you have a working solution then that's the way to go!

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ctafflinger's picture

Hmm yes, very strange, but happy it's improving.  I've just always been told to use Vista 32 bit drivers so Im a bit miffed and confused.

Thanks for you input, browsing through the INF file was what got me going in the right direction.

EdT's picture

I've just always been told to use Vista 32 bit drivers so Im a bit miffed and confused.

That is the generic advice because in 99% of cases where there are networking issues in WinPE, using the correct drivers solves them.  However, experience has shown that vendors make mistakes and therefore the actuality does not always follow logic.

It is possible that the original Vista drivers offered by your vendor were not 100% so when they were updated for Win 7, the Vista problem was fixed by the developers but the fact of this change did not reach the release engineers and therefore the Vista drivers are still the old ones. The bigger the company the more likely you are to see this sort of issue creep in, as the various teams may well be separated both geographically and culturally, and the message does not always get across.  Pure speculation but I've lost count of the number of driver issues I have reported back to major vendors over the years.

At least you are finding a way through all the issues and are coming to a working solution. ;-))

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

rmrotuna's picture

Hello. I was very happy to have found this thread. I have not been able to network the GBE using ANY of the Boot Wizard options. The OP on this thread said they found a way with WinPE. Can you please give me the details? I am the Director of tech for a school district and I am under the gun to get MANY of the 7320 systems ready before the year starts.

Thank you.

ctafflinger's picture

I have eventually gotten it to work a couple different ways.  The first way was to download the 32bit Vista driver from here:

After I added that to WindowsPE, it found the driver as you would hope and imaged...albeit pretty slow.

So if you want it to image a bit faster, download the 64bit version from the same site (or from HP) and then modify the GBE settings by removing the Universal drivers from the GBE Template and adding a new one as NDIS.  Then you have to set the template for the machine you are ghosting.

Hopefully that makes sense, didnt' have much time to type that out.  If you have any questions or need more specifics then let me know.