Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

HP Z420 WINPE 2.1 Issue

Created: 03 Oct 2012 | 7 comments

Hello All,

 I have a new HP Z420 that when I attempt to deploy an image that it doesn't see the hard drive after intial boot screen. I have tried loading the storage driver from HP with no avail since they don't have a Vista driver. I also tried importing the Texas Instuments controller driver in to the preboot as well and receive "Driver did not match device class filter" since it's written for both x86 and x64.

Any suggestions would be a great help!

Thanks,

Kyle

Comments 7 CommentsJump to latest comment

BBC's picture

Hi Kyle,

If you download the entire package (sp57814.exe) from HP for the Z420/620/820, and extract this out, you will usually get the controller and chipset drivers for all OS'es - This is how I have done it and found amongst the for me useless 2k/XP/2003 INF files also the ones I needed to update WinPE.

I'm aware that the package has 500+ MB if you down load it for Win7, but that included at least all I was looking for.

Hope this helps,

-BBC

ATLRoach's picture

BBC-

Thanks for the suggestion, tried it with no avail. I received the same error "Driver did not match device class filter" when attempting to import. Also wouldn't take it through Bootwiz as well. Any other suggestions?

I wish they would release a hotfix with WinPE 3.1 before CMS 7.5.

BBC's picture

Maybe a silly question, but do you use the wizard to inject drivers or are you manually doing this? I usually do not rely on a wizard, but grab the WIM and:

- Mount it;

- Inject drivers required;

- Capture with max compression again (saves space);

- Unmount and use the captured WIM.

Since 6.8x times I had issues with the wizards and stopped to rely on that as manually injecting drivers usually works much more reliable here.

MCTech's picture

i have syspreped an HPZ400 running windows XP, but when i try to use it on a Z420 i get a blue screen. When i use the image on any other hardware (XW6400) the image is good and I can finish deploying the Win XP image. How do i get it to work on a Z420 machine. Thanks.

cadalpias's picture

Was there ever a resolution for this? Did you find the storage drivers for WinPE 2.1?

ATLRoach's picture

No I haven't found a resolution. I have been involved in other priorities and haven't had time to mess with it.

cadalpias's picture

I actually figured this out yesterday after I posted here. Installing the intel storage drivers from this driver pack worked great.

http://h20000.www2.hp.com/bizsupport/TechSupport/S...

Hope this helps you out.