Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

HttpWebRequest_WebException_RemoteServer

Created: 08 Aug 2012 • Updated: 10 Aug 2012 | 10 comments
This issue has been solved. See solution.

Hello,

Device Management > Configuraiton Editor and on the right click on Android Configuration and click on passcode and I get this Error on the top in red ....

 

HTTPWebRequest_WebException_RemoteServer.  Arguments: NotFound.  Debugging resource strings are unavailable.  Often the key and arguments provide sufficent information to diagnose the problem.

 

Could this have something to do with the Silverlight client???  I installed 5.0

 

Thanks!

Discussion Filed Under:

Comments 10 CommentsJump to latest comment

Mina Gerges's picture

I dont think it is related to silverlight, might be related to SSL communication from NS to MDM SS

Under Settings > Mobile Management Server Settings, click the edit icon for the site servers,  then check the box "Ignore SSL Certificate Warnings" under "NS to MMS communication"

Althoug i prefer to post the NS log error so i would point to you what might be the actual cause.

WildPacket's picture

 

Thanks Mina. 

I followed your suggestion but no luck. Where are the NS log error/file located? 

When I just click on Configuration Editor under Device Management then on the right side at the

top I see "Unable to connect to Configuraiton Manager Service. Please check your service URL"

Mina Gerges's picture

Hi WildPacket,

Please post screenshots as well. You can find the NS logs in C:\ProgramData\Symantec\SMP\Logs

also zip and attach the contents of the following folder C:\Program Files (x86)\Symantec\Mobile Management\Data\nlog

WildPacket's picture

 

Thanks Mina. I have attached 2 files.  One is screenshots and one for nlog folder. I ran fidler and it does indicate something but I am not able to decode it.

AttachmentSize
SMM ScreenShot.docx 188.83 KB
nlog.zip 53.43 KB
WildPacket's picture

I applied SSL back to my site and now I see the following in the log file:

 

2012-08-09 12:15:07.8993 ERROR FeedbackThread : WS APNS.GetFeedback() exception. System.Net.WebException: The request failed with HTTP status 403: Forbidden.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Odyssey.CommandService.APNS.APNSWS.GetFeedback(String siteserverid)
   at Odyssey.CommandService.FeedbackThreadManager.GetFeedbackWorkList()

Mina Gerges's picture

Hi WP,

 

Your issue is caused that you are forcing SSL communication.

1- To force SSL "Require SSL in IIS setting" you will need a special configuration for that. uncheck "require ssl" even if you set ignore client certificate.

2- While you uncheck require ssl, you still can use SSL communication, however, the SSL certificates subject sould match the FQDN used for the SMP and MDM SS as they are communicated.

3- I see that you didn't configure the APN certificate settings, the APN cert is a must for iOS enrollment

WildPacket's picture

 

Thanks Mina,

I have tried removing the SSL Certificate and the result is same.  SSL cert do match the FQDN.

We will only be using Androids.

 

Mina Gerges's picture

please include the latest NS log files just after reproducing the issue. also check if you have windows authentication installed on your SS.

WildPacket's picture

I called Symantec Support and the issue is resolved.  This is what the person did to address this issue:

Added the site to Trusted Sites Security Zone and then Click on Custom level > scroll all the way down and select the radio button "Automatic logon with current user name and password"  Now it works with Https:// and Http:// both.

He mentioned that Silverlight was not handling the authentication process very well ...

Thank you for all your assistance Mina :o)

Cheers!!

SOLUTION
Mina Gerges's picture

Hi WP,

Thank you for your feedback, I've noticed your support case. Glad that your issue is resolved.

Regards,