Video Screencast Help

Hushmail SMTP Server and PGP 10.1.2 Build 9 on OS X 10.6.7

Created: 29 Jun 2011 • Updated: 30 Jun 2011 | 5 comments

After fresh install of PGP 10.1.2 Build 9 on my freshly installed Macintosh OS X 10.6.7,  Mac Mail no longer sends outgoing mail via a Hushmail email account.

Incoming mail work fine.

Inspection of PGP Desktop:PGP Messaging reveals a Service apparently created by the PGP installation which has a email address value of "unknown@hushmail.com".

Attempt to send via Mac Mail results in prompt from PGP instructing that the Mail application should be set to not use SSL and let PGP handle that SSL.  If that directive is ignored, Mail's activity panel reports perpetual "Checking account connections" and "Sending message" (no timeout), and the outbound message will not be sent.

Hushmail requires a special "private desktop access password" which is retained by Mail's advanced settings for each email account.  (Again, prior to installing PGP, Mail was properly configured with this private password and outbound email functioned properly.)

If Mail is configured as PGP directs, not to attempt SSL, then PGP creates another Messaging Service.  However, the value for incoming mail server is set to the "smtp.hushmail.com" instead of the proper value of "imap.hushmail.com".

The PGP advanced settings panel for the associated service has no provision for holding Hushmail's "private desktop access password".

Understanding today is the first time I have used the Symantec forum software (having used the PGP Corp sites for years), I searched this forum for the word "hushmail" and obtained a null result.

So, is there a tech note about how to configure Desktop PGP 10.1.2 for OS X 10.6.7?  If so where may I access it?  If not, has anyone the answer?

 

=====================================

PROBLEM REPORT UPDATE of June 30, 2011:

Partial contents of PGP LOG after hitting Send button of MacMail

 

2011-06-30 10:07:25: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) clientThread:] Servicing client 127.0.0.1

2011-06-30 10:07:25: Proxying connection from Mail to 65.39.178.33 587

2011-06-30 10:07:25: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) accountForIP:port:haveTLS:] Found account for host: imap.hushmail.com

2011-06-30 10:07:26: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) connect:port:haveTLS:] Attempting TLS connection with 65.39.178.33:587

2011-06-30 10:07:26: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) connectTo:port:timeout:socket:] Connecting to 65.39.178.33:587

2011-06-30 10:07:27: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) negotiateTLS] Attempting to establish a TLS session with 65.39.178.33

2011-06-30 10:07:27: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) negotiateTLS] Failed to establish TLS session with 65.39.178.33 (err=-11249)

2011-06-30 10:07:27: (Thread 2967781376) -[CPGPUDSMTPProxy (0x408E900) connect:port:haveTLS:] TLS negotiation with 65.39.178.33 failed (err=-11249)

Obviously, there is more in the log but I fear publishing it as I know not whether a password or passphrase is in the debug log as clear text.

Comments 5 CommentsJump to latest comment

Tom Mc's picture

This is from Hushmail Help.  It is a little dated, but might take care of the problem:

To send secure email to a Hushmail account, configure PGP 8.0 for Windows as follows:

  1. Right-click the PGP icon in the system tray
  2. Select Options…
  3. Click the Servers tab
  4. Click the New button
  5. Select PGP Keyserver LDAP
  6. In the Name field, enter keys.hush.com
  7. Click the OK button

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Fred King's picture

I suspect that is to retrieve a public key for local encryption.

I am not attempting to encrypt the outgoing mail.

I have searched the interface of 10.1.2 for any analog fields to those described in that old PGP 8.0 for Windows note.  I see none.

Suggestions welcome.

Tom Mc's picture

Hushmail appears to have greatly changed in the years since I used it.  I don't know if adding their keyserver will help, but it seems unlikely to harm anything.  You can add it using the Keyservers button on the Keys tab of PGP Options. 

You can manually make any server changes that are necessary to the auto created messaging service(s).

If you don't want Hushmail server email processed by the PGP email proxy, you can let PGP do the auto messaging service creation, but then right click on it and select Disable Service.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Fred King's picture

Adding keys.hush.com has had no effect on the outbound mail process—outbound mail continues to stall in a perpetual loop.

I am using the Macintosh version, so most the Windows product nomenclature and interface instructions provided do not apply semantically nor syntaxically.

Most Macintosh systems have no "right click" mouse.  And the Macintosh version of PGP does not generally use buttons or tabs.  Instead it uses menu items and panels.

I achieved the key server addition as follows:

Select the Open PGP Desktop Menu Item of the pull down of the PGP icon located in the Finder menu bar.

Select "Add Keyserver ..." menu item of PGP Desktop application's menu bar "Keys" pull down menu.

Enter  "keys.hush.com" into the field labeled "Server Name" on the "New Key Server" window.

I do not know what is  "auto messaging service creation", but I did read a manual note suggesting that unchecking the box labeled "Warn if email client attempts SSL/TLS" on the "Server Settings" panel, and selecting "Do not attempt" might additionally stop PGP from managing the Mail application's connection to the mail server. Alas, changing these settings has no effect I discern.

Suhaib's picture

Try the suggestions in the section titled, Troubleshooting PGP Messaging Services, page 96, of the User Guide.