Video Screencast Help

Hyper V Cluster VM Backup fails when NOT using dynamic Inclusion

Created: 15 Dec 2011

We have a cluster of 8 nodes with over a dozen VM's and use Backup Exec 2010 to backup VM's.  We perform a daily backup that includes a couple specific VM's from the cluster along with other types of data, and once a week we perform a complete (dynamic inclusion) backup of all VM's in the cluster.  Both the daily and weekly backs were working, and then recently the daily backups started failing to get the specified VM's with the error (see attached screenshot for details):

Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them. Check if files were deleted or renamed.

I looked into it, and discoved that if I tried to change the VM's selected in the daily backup selection list (which is agonizingly slow to browse through, by the way), through the 'cluster' dns name, all the VM's show 'none' in the details pane, except for the ones currently running on the cluster's host node (The node the cluster DNS name is currently resolving too).

I also noted something else, while looking at a selection list, I noticed a VM which was miss-named, so I fixed it through the hyper-v consolve of the node currently running that VM, refrehsed my selection list view and (eventually, again slow as moles-asses) it updated.  So I know it's getting currently information from the cluster, it just can't see details about the VM's on other nodes but the cluster host node?

Any ideas as to a solution for this, or where to concentrate my efforts?  Any help appriciated, thanks!