Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Hyper-V incrementals with BE2014

Created: 30 Jul 2014 • Updated: 31 Jul 2014 | 6 comments
This issue has been solved. See solution.

Hello,

Currently, we have a BE2012 backing up our environment. This includes two hyper-v clusters with about 6 VMs each. I have seen numerous information regarding BE2014 being able to take hyper-V incrementals when the hyper-V host is running Windows Server 2012. However, our hosts are on 2008 R2. I can't find any information if incremental VM backups will work properly with BE2014 backing up a Hyper-V 2008r2 host. Can someone help me out with this? Our license for BE2012 expires at the end of August, so I will be going to 2014 within the next few weeks. 

Thank you

Operating Systems:

Comments 6 CommentsJump to latest comment

gpn43's picture

OK, so BE2014 cannot perform block incremental backups of Hyper-V VM's unless:

1. BE2014 media server is running on a Windows Server 2012 machine

and

2. The Hyper-V hosts are also running Windows Server 2012

In other words, if one of those two criteria are not met, then incrementals will not work correctly? 

Thanks for the quick response.

VJware's picture

This criteria applies only if you are going to use Microsoft's incremental backups for Hyper-V and not BE's incremental backups.

gpn43's picture

OK. Thanks for clarifying that, but I am still unclear on a couple things. If my BE media server AND hyper-V hosts remain on 2008r2, when I upgrade to BE2014, will the BE incrementals work on hyper-V vm's? 

Right now, on BE2012, it just takes a full backup everytime, because it detects a change in the .VHD. So I guess the root of the question is - If all servers are on 2008R2 (VM's, Hyper-V host, and BE Media server), can BE2014 do block based incrementals on the virtual machines?

Sorry, but I just want to know if I need to upgrade my Hyper-V hosts to Server 2012 sooner than I had planned to. 

Thanks for all the replies. 

VJware's picture

Yes, incrementals of Hyper-V VMs can be done by BE 2014 when all servers are running Win 2008 R2. In fact, incrementals of Hyper-V was introduced in BE 2012, so if incrementals aren't running as expected, I would recommend you to log a formal support case instead.

SOLUTION
gpn43's picture

Thanks for the clarification. We will be upgrading to BE2014 in the coming weeks, so I will get that upgraded and then open a case if I am still having problems.

Thank you.

pkh's picture

You should be o.k., but there are some limitations. I don't have the document right now.