Video Screencast Help

I am unable to restore a single file on a virtual machine

Created: 27 Sep 2013 | 11 comments

I am currently running Backup Exec 2012 SP2 on a windows server 2003 R2 x64.  I also have the Agent for VMware and Hyper-V installed as well as a RAWS for the physical server and another physical Hyer-V Host.  So I have 2 RAWS and the Agent for VMware and Hyper-V.

I am able to backup the virtual machines everynight and I can do a complete restore of the virtual machines.  However, I am unable to just restore a single file on one of the machines.  When I try to run the job I get the following error.

The job failed with the following error: The resource could not be restored because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.
Make sure that the correct version of the Remote Agent is installed and running on the target computer.

I don't need a RAWS fr each of my virtual machines do I?

Any help would be greatly appreciated.

Operating Systems:

Comments 11 CommentsJump to latest comment

teiva-boy's picture

If you want to restore files into or from  within your VM's, yes a RAWS agent needs to be installed within the guest.

However, you can still continue to perform your image based backups as you are.  The agent is more there for file level recoveries (indexing FS upon backup), as well as allowing the file write operation into a host/client

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

pkh's picture

You do not need to buy any RAWS licences to install RAWS in your VM's.  You are entitled to install as many RAWS as you like in the VM's hosted by the host which is licenced for AVVI/Hyper-V

Tactical-N8's picture

Hi pkh,

I hope you are correct, since that is what the Symantec Salesman told me when I purchased the Hyper-V agent.  However, I still can't seem to get this to work.  If I right-click on one of my virtual machines and select "establish trust" I get an error that says I need the RAWS.  Is there another way that I should be doing this?

Thanks for your reply.

pkh's picture

Before you can establish trust you must push out and install the RAWS in the VM's. Click on the BE button  ---> Installation and Licencing ----> Install Agents.... to do so.

Tactical-N8's picture

okay thanks for the advice. I got the agent installed on all of the VM's now.  However, now when I try to restore a file I get this error message:

The job failed with the following error: Could not find components to mount a VHD file. Please ensure that the Microsoft Virtual Server VHDMount component is installed.
 

pkh's picture

Now that you have installed RAWS in the VM's, have you tried doing another backup of the VM's and then restoring the files?

Tactical-N8's picture

pkh,

I was actually still trying to restore a file from before I installed the RAWS.  I will try this on a new backup and let you know what I get.

thanks for your help!

Tactical-N8's picture

Okay, I just tried to restore a file from a new backup that ran after I pushed the RAWS to the VM.  Still no luck, getting the same error message:

The job failed with the following error: Could not find components to mount a VHD file. Please ensure that the Microsoft Virtual Server VHDMount component is installed.

When the job runs, it is taking a very long time.  I'm only trying to restore small files (<1GB) but the byte count goes up to like 30GB (the size of the entire virtual disk) and it says "Staging". Normally I can restore a small file quickly.

And like I said before, I can restore an entire VM, just not single files.

pkh's picture

If you are doing a restore from tape, then the backup set needs to be staged to disk first.  This means the entire VM will be staged.  If the staging takes a long time, you can duplicate the backup set to disk first and then do the restore from the disk backup set.

Your error might be due to the fact that you do not have sufficient disk space for the staging which can be avoided by duplicating your backup set to a disk with more space.

Tactical-N8's picture

Well, I spent over an hour and a ahlf on the phone with Symantec yesterday and they finally told me that Grannular Recovery Technolgy is not yet supported for Windows Server 2012 but it was possible that there would be a service pack out someday to fix this issue.  So I can only restore a complete virtual machine at the .VHD level.  I can't restore individual files or components.  This is not an acceptable backup solution.

This is quite dissapointing as I was told that Service Pack 2 was going to enable support for Windows Server 2012.  So when it was released I purchased the Hyper-V agent.

The only thing I found that works is if I backup the Hyper-V host machine and then also backup each server with a separate job using the RAWS.  This however creates a lot of redundant data and we don't have enough storage space to do this with tape.

So I made a huge mistake in choosing to purchase Backup Exec to 2012 to backup our Virtual environment since all of our servers are running Windows Server 2012.  I now have to look for other products so that we are protected.

bummersad

Andrew Madsen's picture

Does anyone know if this is an issue with NetBackup as well?

The above comments are not to be construed as an official stance of the company I work for; hell half the time they are not even an official stance for me.