Video Screencast Help

I can't get my date pickers to default to today's date

Created: 02 Apr 2013 • Updated: 05 Apr 2013 | 11 comments
This issue has been solved. See solution.

I've checked the "Start Today" box and for some reason, the date pickers are defaulting to 1/1/1990.

What am I missing?

Comments 11 CommentsJump to latest comment

reecardo's picture

It appears to be working fine on my 7.5(ish) build. Attached is a package that works properly for me (ignore any upgrade warnings)

What version/build number are you using?

AttachmentSize
WebFormsProject2.package 1.39 MB
HarrisT's picture

There are two ways you can do this.

First option:
While configuring the the "Date Picker" component, ensure the "Start Today" checkbox is selected.

Second option:
Just before the Form Builder component, add a "Get Current Date" component to the Workflow. Name the output something meaningful, "DateToday" for example.
Now configure the "Date Picker" component, ensure "Start Today" is deselected, and configure the component to use the "DateToday" variable you just created.

I just tested in my environment and both methods work correctly.

oshgosh's picture

HarrisT: I've tried both of those options already with no luck :(

Reecardo: What do I do with this file?

reecardo's picture

Crack open the .package and see if the date comes up as the current date or 1900 (a package file is basically just a zipped project... double clicking it should make Designer try and open it)

My build is greater than yours so you'll probably get an upgrade warning... still try and open it. It might not be able to open up though.

If opening it doesn't work, could you describe the setup of your datepicker with screenshots or similar?

oshgosh's picture

I opened your workflow, tried to run it in debug mode, and got this error (Project has validation breaks, please correct LogicBase.Core.Models.Dialog.FormDialogProject :: Resource web.config was not found, please correct)

Not sure what version I'm using either.

rhamner's picture

When you get this error navigate to the project folder in Windows Explorer and you should see Web.Config file with an extension like .bak or .old. Just remove that extention and reload the project.

HarrisT's picture

To check your version, open Workflow Manager and navigate to Help -> About. If both of the methods I suggested are not working it is likely you're encountering a defect on the version you're running.

AnaMan's picture

We had such problem when the system date/time format set on the workflow server was different from the date/time format set on the computer the process was serviced in web browser.

oshgosh's picture

Version 7.1. Thanks HarrisT.

AnaMan, was the date wrong when you ran workflows in debug mode? Isn't that all local?

HarrisT's picture

Will you give me the full version? For example, 7.1.1460.1791.
7.1 has many different builds of Workflow.

I would guess there may be a defect with this component in the version of Workflow you're running.

SOLUTION