Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

I rebooted the server (single node cluster) but HA is not starting.

Created: 05 Nov 2012 • Updated: 04 Dec 2012 | 8 comments
This issue has been solved. See solution.

I have a server that after rebooting it, HAD is not starting. I have to manually run the "hastart -onenode" command to start it. Is there some configuration I missed?

 

root:/$ oslevel -s
6100-07-05-1228
root:/$ lslpp -l | grep VRTSvcs
  VRTSvcs                  5.1.112.0  COMMITTED  Veritas Cluster Server by
  VRTSvcsag                5.1.112.0  COMMITTED  Veritas Cluster Server Bundled
  VRTSvcsea                5.1.112.0  COMMITTED  Veritas High Availability
  VRTSvcs                  5.1.112.0  COMMITTED  Veritas Cluster Server by
  VRTSvcsea                5.1.112.0  COMMITTED  Veritas High Availability

 

\\ When I checked the startup script (/etc/init.d/vcs.rc), I see that it should start it...

        systems=`$GREP '^system' $VCS_CONF/conf/$CONF_DIR/main.cf 2> /dev/null | /usr/bin/wc -l`
        if [ "$systems" -eq "1" ]; then
                gabconfigured=`$GABCONFIG -l 2> /dev/null | $GREP 'Driver state' | $AWK '{ print \$4; }'`
                if [ "$gabconfigured" = "Configured" ]; then
                        $HASTART
                else
                        $HASTART -onenode
                fi
        else
                $HASTART
        fi

 

root:/etc/VRTSvcs/conf/config$ grep '^system' ./main.cf 
system node1 (
root:/etc/VRTSvcs/conf/config$ grep '^system' ./main.cf |wc -l
       1

 

 

Comments 8 CommentsJump to latest comment

mikebounds's picture

If this is Linux, do  you have  "ONENODE=yes" inside the file /etc/sysconfig/vcs?

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

mikebounds's picture

Sorry, should have read properly as I can see you used "lslpp" in post which is AIX.  Is GAB configured (i.e /etc/gabtab exists) - if so it needs to read something like

/sbin/gabconfig -c -n 1 

The 1 at the end is the important bit and if gab is configured, then llt will need to be configured correctly as well (/etc/llttab)

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

Tander's picture

The setup for this is no GAB or LLT configuration and I believe this is fine as this is only one node cluster.

mikebounds's picture

You don't need GAB and LLT for a one-node cluster, but you can use GAB and LLT for a one-node cluster and if it was setup wrong then this would prevent cluster starting in RC scripts as it would not use "hastart -onenode", but if you have no gabtab and llttab files, then RC scripts should be running "hastart -onenode", so maybe this rc script is disabled at an AIX level, if hastart -onenode works manually.  What I would recommend is reboot and if VCS does not start then manually run /etc/init.d/vcs.rc and if this works, then this would suggest it is not being called, and if it doesn't work, you may see an error message as to why.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

Pranav Sarwate's picture

On aix the VCS configuration file is located at /etc/default/vcs. Try setting the following attributes in this file and check if VCS starts on reboot

VCS_START=1

ONENODE=yes

Since, hastart -onenode works when run manually, I feel that the above change should resolve the issue for VCS start on reboot.

Tander's picture

Mike ,thanks for the response on this forum...

 

Sorry for the late reply.. as I resolved the issue by looking into the script and making it verbose .. thats when I found that this file is being checked... The message is not helpful though.. I hope that Symantec will message something about this variable...

$ /etc/init.d/vcs.rc start
Silent Feature  <<<<<<<<<<<<<<< what is this ???? 

       # check to see if this script is allowed to run
        if [ "$VCS_START" != 1 ]; then
                echo "Silent Feature"
                exit 2
        fi

https://sort.symantec.com/public/documents/sf/5.1/aix/html/vcs_admin/ch_vcsconfiguration_concepts19.html

 

Veritas packages were installed via installer script but I didn't configure the cluster via installer. I did it manually as there's no involvement of LLT / GAB etc... 

 

it seems to me the installer script change it  from by default 1  to 0 ... anyway.. it is working now though...

 

 

 

 

 

 

Tander's picture

Yes, I just found out this needs to set manually if you dont use the installer script to configure your cluster..

https://sort.symantec.com/public/documents/sf/5.1/aix/html/vcs_admin/ch_vcsconfiguration_concepts19.html

 

Which should not be the case, cause it is said by default  it is set to 1 ...

 

Anyway, I couldn't reboot it so I have to tshoot the startup script and the message is not really helpful,... thats when I found out that this variable file must be modified...

 

root $ /etc/init.d/vcs.rc start
Silent Feature   <------------------------  ??????

 

the script checked this if it is set to 0 ...  Very weird message .. There should be more informational message when this variable is setup to 0 .. and not Silent Feature .. what is that???

       # check to see if this script is allowed to run
        if [ "$VCS_START" != 1 ]; then
                echo "Silent Feature"
                exit 2
        fi

 

 

 

Anyway, everything is good now.. I run the startup script and it works...

 

 

 

 

 

 

SOLUTION